Bug 147991 - Add a release notes field to the csv files used by rhn-download-manager
Add a release notes field to the csv files used by rhn-download-manager
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn370
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 11:26 EST by John Wregglesworth
Modified: 2007-04-18 13:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn370
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-02-14 11:26:52 EST
Description of problem: A release notes field needs to be added to the
csv files used by rhn-download-manager. This probably means that the
field delimiter used in the csv files will need to be changed. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Wregglesworth 2005-02-15 09:57:41 EST
The release notes field is actually a release_notes_url field in the
csv files. This is because the rhnDownloads table stores the url to
the release notes, not the actual release notes.
Comment 2 John Wregglesworth 2005-02-17 16:49:41 EST
NOTE: Steps 1-5 are the same as steps 1-5 in the test plan for 147988.

1. If you don't already have the rhn_superuser role in the environment
that you're testing in, ask someone to grant it to your user. Once you
have the rhn_superuser role, you need to set up your user with the
role through the web interface.

2. Put together some tarballs with some random stuff in them. It
shouldn't matter what the tarballs have in them.

3. Have someone create a new directory in whatever environment you
will be testing in. This directory should be under the mount_point,
which is defined in the rhn_server.conf file in /etc/rhn/defaults/.

4. Once you have the path to the new directory, get the file size and
md5sum and create a csv file. You can get the format that the csv file
needs to be in by running rhn-download-manager using the --list
<channelName> option. It doesn't matter what channel you use, but I'd
recommend one with a small number of packages in it. At least one of
the files should have a download_type of "channel-xml-dump".

5. Next, have someone place the tarballs you made in step 2 in the
directory that was made in step 3.

6. Now you need to add information to the release notes field of at
least one of the entries in the csv file. Normally, the the release
notes field would be a URL pointing to the relevant notes, but since
you're most likely adding packages that don't have any relevant
release notes you can put anything you like here (as long as it
doesn't contain any commas).

7. Run rhn-download-manager with the --upload <csv-file> option, using
the csv file finished in step 6.

8. Run rhn-download-manager with the --list <channelName> option. The
channel name should be the same one you used in the csv file. Look at
the output that results and make sure that the release notes you used
in the csv file were returned when you ran --list.

9. Finally, run rhn-download-manager with the --delete <csv-file>
option. As before, use the csv file you finished creating in step 6.
This is to make sure that the new release notes field doesn't screw up
the --delete option.

Expected Outcome:
Using rhn-download-manager with --upload and --delete and --list
should work without problems. --list should include the new field when
it lists the downloads associated with a channel.
Comment 3 John Wregglesworth 2005-02-22 11:11:27 EST
The above test plan is missing a step. Somewhere is steps 1-5 a new
channel that can have downloads associated with it will need to be
created. I think either misa or chris can do that. The channel that
gets created is the one that's used in the other steps.
Comment 4 John Wregglesworth 2005-09-29 16:52:34 EDT
This change was for an internal tool and is already in use.

Note You need to log in before you can comment on or make changes to this bug.