Bug 1479919 - PR 779 routing docs do not document context
PR 779 routing docs do not document context
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Michael Burke
zhaozhanqi
Vikram Goyal
3.7-release-plan
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 14:22 EDT by Michael Burke
Modified: 2017-09-11 21:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-07 17:13:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Burke 2017-08-09 14:22:45 EDT
The route object can take a context (eg: foo.com/context/stuff). This is not currently in the docs.

https://docs.openshift.com/enterprise/3.0/dev_guide/routes.html

link directly to the route types subsection?

https://docs.openshift.com/container-platform/3.5/architecture/core_concepts/routes.html#route-types

The reason I ask is that currently the routes section starts off by explaining routes, but then details a bunch of stuff specifically about routers, which a lot of regular users would not be able to create or modify.

They might miss some of the overview details, though...


For details: https://github.com/openshift/openshift-docs/issues/779
Comment 2 Michael Burke 2017-08-15 12:50:26 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1436817

*** This bug has been marked as a duplicate of bug 1436817 ***
Comment 3 Michael Burke 2017-08-16 11:00:18 EDT
Not a duplicate. Closed in error. Reopening as ON_QA
Comment 4 Michael Burke 2017-08-16 11:01:58 EDT
@vikram -- is the someone in QE appropriate to review this change; assuming QE review in required for a change of this nature?
Comment 5 zhaozhanqi 2017-08-29 01:49:44 EDT
The changes LGTM, Could you merge this PR, I will verify this bug after that.
Comment 6 Michael Burke 2017-09-07 17:13:21 EDT
Change is live
https://docs.openshift.org/latest/dev_guide/routes.html

Note You need to log in before you can comment on or make changes to this bug.