Bug 1479932 - gi.overrides.BlockDev.LVMError: Process reported exit code 5: Volume group "VolGroup00" not found
gi.overrides.BlockDev.LVMError: Process reported exit code 5: Volume group ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libblockdev (Show other bugs)
27
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:263351e701884e54bad32436475...
:
Depends On:
Blocks: F27FinalBlocker F27FinalFreezeException
  Show dependency treegraph
 
Reported: 2017-08-09 14:55 EDT by Joachim Frieben
Modified: 2017-10-03 14:07 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-03 14:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.22 MB, text/plain)
2017-08-09 14:55 EDT, Joachim Frieben
no flags Details
File: anaconda.log (63.04 KB, text/plain)
2017-08-09 14:55 EDT, Joachim Frieben
no flags Details
File: environ (591 bytes, text/plain)
2017-08-09 14:55 EDT, Joachim Frieben
no flags Details
File: journalctl (413.58 KB, text/plain)
2017-08-09 14:55 EDT, Joachim Frieben
no flags Details
File: lsblk_output (2.66 KB, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details
File: lvm.log (266.62 KB, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details
File: nmcli_dev_list (2.48 KB, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details
File: os_info (606 bytes, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details
File: program.log (81.48 KB, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details
File: storage.log (334.58 KB, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details
File: ifcfg.log (3.69 KB, text/plain)
2017-08-09 14:56 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2017-08-09 14:55:28 EDT
Version-Release number of selected component:
anaconda-core-27.19-2.fc27.x86_64

The following was filed automatically by anaconda:
anaconda 27.19-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/gi/overrides/BlockDev.py", line 824, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1966, in _setup
    blockdev.lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1839, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 377, in setup
    self._setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1936, in setup
    return DMDevice.setup(self, orig)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1839, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 695, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 325, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 163, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1112, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 365, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 252, in run
    threading.Thread.run(self)
gi.overrides.BlockDev.LVMError: Process reported exit code 5:   Volume group "VolGroup00" not found
  Cannot process volume group VolGroup00


Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-WS-Live-Rawhide-20170805- rd.live.image quiet kaslr enforcing=0
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.13.0-0.rc3.git4.1.fc27.x86_64
other involved packages: python3-blivet-2.1.9-3.fc27.noarch, system-python-libs-3.6.2-5.fc27.x86_64, python3-blockdev-2.11-1.fc27.x86_64
product:        Fedora
release:        Fedora release 27 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 Joachim Frieben 2017-08-09 14:55:49 EDT
Created attachment 1311344 [details]
File: anaconda-tb
Comment 2 Joachim Frieben 2017-08-09 14:55:51 EDT
Created attachment 1311345 [details]
File: anaconda.log
Comment 3 Joachim Frieben 2017-08-09 14:55:53 EDT
Created attachment 1311346 [details]
File: environ
Comment 4 Joachim Frieben 2017-08-09 14:55:59 EDT
Created attachment 1311347 [details]
File: journalctl
Comment 5 Joachim Frieben 2017-08-09 14:56:01 EDT
Created attachment 1311348 [details]
File: lsblk_output
Comment 6 Joachim Frieben 2017-08-09 14:56:06 EDT
Created attachment 1311349 [details]
File: lvm.log
Comment 7 Joachim Frieben 2017-08-09 14:56:07 EDT
Created attachment 1311350 [details]
File: nmcli_dev_list
Comment 8 Joachim Frieben 2017-08-09 14:56:09 EDT
Created attachment 1311351 [details]
File: os_info
Comment 9 Joachim Frieben 2017-08-09 14:56:11 EDT
Created attachment 1311352 [details]
File: program.log
Comment 10 Joachim Frieben 2017-08-09 14:56:17 EDT
Created attachment 1311353 [details]
File: storage.log
Comment 11 Joachim Frieben 2017-08-09 14:56:18 EDT
Created attachment 1311354 [details]
File: ifcfg.log
Comment 12 Martin Kolman 2017-08-11 07:13:04 EDT
Definitely looks like something storage related, so reassigning to liblockdev for further triage.
Comment 13 Jan Kurik 2017-08-15 03:19:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 14 Fedora Blocker Bugs Application 2017-10-01 03:53:35 EDT
Proposed as a Blocker and Freeze Exception for 27-beta by Fedora user frieben using the blocker tracking app because:

 Anaconda fails to process a LUKS-encrypted volume group after the setup stage even though the password had been entered successfully, and individual volumes had been assigned when specifying the disk layout. The installer aborts and leaves the user with an unbootable system because this happens after reformatting the unencrypted /boot partition. This behaviour violates the following requirement:

"The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration."
Comment 15 Andre Robatino 2017-10-01 03:55:06 EDT
You want this to be a Final blocker, Beta has been approved already.
Comment 16 Vratislav Podzimek 2017-10-02 05:19:36 EDT
Joachim, could you please try to reproduce this with the current F27 images? I just tried reusing encrypted LVM volumes for a new installation and everything worked just fine.
Comment 17 Kamil Páral 2017-10-02 12:56:24 EDT
Discussed at blocker review meeting [1]:

Punt (delay decision) - We'll wait until this has detailed reproduction steps and somebody else manages to successfully reproduce it.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-10-02/
Comment 18 Lukas Brabec 2017-10-03 05:37:24 EDT
I wasn't able to reproduce this with Fedora-Everything-netinst-x86_64-27-20171002.n.1.iso. 
I successfully reused encrypted LVM from previous installation (decrypt in anaconda, reformat / and /boot, install the system a boot with the password set in previous installation).
Comment 19 Joachim Frieben 2017-10-03 14:03:19 EDT
(In reply to Martin Kolman from comment #12)
This issue occurred using a Fedora 27 development live image on real hardware. At that time, Fedora 27 already featured current package libblockdev-2.12-1.fc27.
As of Fedora-Workstation-Live-x86_64-27_Beta-1.5, the install performs successfully without the crash reported above. It therefore seems that setting the relevant component to libblockdev was not appropriate.
Comment 20 Joachim Frieben 2017-10-03 14:07:10 EDT
I have to correct myself: the original install was actually using blockdev-2.11-1.fc27.

Note You need to log in before you can comment on or make changes to this bug.