Bug 1479954 - provision rhev vms with cloudinit user-data templates
provision rhev vms with cloudinit user-data templates
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - RHEV (Show other bugs)
6.2.10
Unspecified Linux
unspecified Severity medium (vote)
: 6.2.12
: --
Assigned To: Ivan Necas
Sanket Jagtap
http://projects.theforeman.org/issues...
: Triaged
Depends On: 1189813
Blocks: 1317530 rhci-common-installer
  Show dependency treegraph
 
Reported: 2017-08-09 15:47 EDT by Ivan Necas
Modified: 2017-09-25 14:59 EDT (History)
28 users (show)

See Also:
Fixed In Version: rubygem-rbovirt-0.0.38.1-1, foreman-1.11.0.85-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1189813
: 1480349 (view as bug list)
Environment:
Last Closed: 2017-09-25 14:59:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test-User data template (1.71 KB, text/plain)
2017-08-29 11:23 EDT, Sanket Jagtap
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2221221 None None None 2017-08-09 15:47 EDT
Foreman Issue Tracker 20591 None None None 2017-08-17 09:28 EDT
Foreman Issue Tracker 8289 None None None 2017-08-09 15:47 EDT
Red Hat Product Errata RHBA-2017:2803 normal SHIPPED_LIVE Satellite 6.2.12 bug fix update 2017-10-12 15:22:49 EDT

  None (edit)
Comment 2 pm-sat@redhat.com 2017-08-09 16:02:54 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/8289 has been resolved.
Comment 5 pm-sat@redhat.com 2017-08-17 10:02:42 EDT
Upstream bug assigned to inecas@redhat.com
Comment 6 pm-sat@redhat.com 2017-08-17 10:02:53 EDT
Upstream bug assigned to inecas@redhat.com
Comment 11 Ivan Necas 2017-08-29 08:40:30 EDT
Btw. there is https://bugzilla.redhat.com/show_bug.cgi?id=1406520, that was causing troubles setting up the cloud-inin on the virtualized box:

systemctl status cloud-init-local
● cloud-init-local.service - Initial cloud-init job (pre-networking)
   Loaded: loaded (/usr/lib/systemd/system/cloud-init-local.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2017-08-29 06:16:38 EDT; 2h 22min ago
 Main PID: 492 (code=exited, status=1/FAILURE)

Aug 29 06:16:38 localhost.localdomain cloud-init[492]: self.selinux.restorecon(path, recursive=self....ve)
Aug 29 06:16:38 localhost.localdomain cloud-init[492]: File "/usr/lib64/python2.7/site-packages/seli...con
Aug 29 06:16:38 localhost.localdomain cloud-init[492]: restorecon(os.path.join(root, name))
Aug 29 06:16:38 localhost.localdomain cloud-init[492]: File "/usr/lib64/python2.7/site-packages/seli...con
Aug 29 06:16:38 localhost.localdomain cloud-init[492]: status, context = matchpathcon(path, mode)
Aug 29 06:16:38 localhost.localdomain cloud-init[492]: OSError: [Errno 2] No such file or directory
Aug 29 06:16:38 localhost.localdomain systemd[1]: cloud-init-local.service: main process exited, cod...URE
Aug 29 06:16:38 localhost.localdomain systemd[1]: Failed to start Initial cloud-init job (pre-networking).
Aug 29 06:16:38 localhost.localdomain systemd[1]: Unit cloud-init-local.service entered failed state.
Aug 29 06:16:38 localhost.localdomain systemd[1]: cloud-init-local.service failed.
Hint: Some lines were ellipsized, use -l to show in full.



The fix for this issue should be delivered in RHEL 7.4 (see https://bugzilla.redhat.com/show_bug.cgi?id=1406520) for more details.
Comment 12 Sanket Jagtap 2017-08-29 11:21:54 EDT
Build: Satellite 6.2.12 snap1 

Verified on RHV Version 4.0.6.3-0.1.el7ev
Red Hat Enterprise Linux Server release 7.4 (Maipo)

PFA Test User data template

Partial log:
Complete!
Uploading Enabled Repositories Report
Loaded plugins: product-id
Note: Forwarding request to 'systemctl enable puppet.service'.
Created symlink from /etc/systemd/system/multi-user.target.wants/puppet.service to /usr/lib/systemd/system/puppet.service.
Redirecting to /bin/systemctl start puppet.service
2017-08-29 11:04:22,929 - util.py[WARNING]: Configuration entry 'tries' is not an integer, using 10 instead
2017-08-29 11:04:22,942 - util.py[WARNING]: /etc/ssh/ssh_host_dsa_key.pub: failed to open, can not phone home that data!
Cloud-init v. 0.7.9 finished at Tue, 29 Aug 2017 15:04:24 +0000. Datasource DataSourceConfigDrive [local,ver=2][source=/dev/sr1].  Up 176.44 seconds
Comment 13 Sanket Jagtap 2017-08-29 11:23 EDT
Created attachment 1319598 [details]
Test-User data template
Comment 15 errata-xmlrpc 2017-09-25 14:59:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803

Note You need to log in before you can comment on or make changes to this bug.