Bug 1479988 - Download page shows wrong product version
Download page shows wrong product version
Status: CLOSED CANTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: releng (Show other bugs)
3.2
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sreenath G
Rahul Hinduja
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 17:09 EDT by Patrick Ladd
Modified: 2018-06-20 23:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-20 23:14:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Ladd 2017-08-09 17:09:10 EDT
Description of problem:
When I load this page: 
https://access.redhat.com/downloads/content/186/ver=3.2/rhel---7/3.2/x86_64/packages

It redirects to this page: (note the ver=3.1) https://access.redhat.com/downloads/content/186/ver=3.1/rhel---7/3.2/x86_64/product-software

with download links to the software, clicking on the packages tab directs to this page:
https://access.redhat.com/downloads/content/186/ver=3.1/rhel---7/3.2/x86_64/packages

Which describes the packages as "Packages for Red Hat Gluster Storage Server for On-premise (v. 3.1 for x86_64)" rather than 3.2 packages.  I haven't determined if the packages being displayed are in fact the 3.1 or 3.2 packages, but the labeling is incorrect either way.



Version-Release number of selected component (if applicable):
3.2

How reproducible:
Always

Steps to Reproduce:
1. Go to https://access.redhat.com/downloads/content/186/ver=3.2/rhel---7/3.2/x86_64/packages

2. Note the incorrect version number in the URL that loads
3. Click on the Packages tab

Actual results:
Header of section shows:
Packages for Red Hat Gluster Storage Server for On-premise (v. 3.1 for x86_64)
Version drop down shows 3.1 as the version and does not offer 3.2 as a version to be selected.

Expected results:
Header of section should show:
Packages for Red Hat Gluster Storage Server for On-premise (v. 3.2 for x86_64)
Version dropdown shows 3.2 as the version selected.

Additional info:
Need to double check which packages are actually offered to make sure they're the right version
Comment 3 Sreenath G 2018-06-20 23:14:10 EDT
The content path for the repos were created at the time of 3.1, and later we decided to use it for all the 3.y versions, which is the reason why 3.1 is appearing in URL. Changing the content path now is not a feasible soultion, as it will disrupt all the customers in production.

Note You need to log in before you can comment on or make changes to this bug.