Bug 1479997 - FLAC tag isn't filled properly
FLAC tag isn't filled properly
Product: Fedora
Classification: Fedora
Component: gstreamer1 (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2017-08-09 17:48 EDT by Bart Ratgers
Modified: 2018-02-01 17:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2018-02-01 17:25:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 785558 None None None 2017-11-14 04:28 EST

  None (edit)
Description Bart Ratgers 2017-08-09 17:48:52 EDT
Description of problem:

After upgrading to Fedora 26 sound-juicer doesn't create a proper FLAC file, the meta-information block in the FLAC file seems to be corrupted. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start sound-juicer and put a CD in the CD-ROM drive
2. Select in upper menu -> Preference -> And choose 'ouptut format' FLAC
3. Select one track to RIP and fill in some meta-information, in case the meta information isn't recieved via MusicBrainz.
4. After finishing check with Nautilus/Files the Audio information. The meta information is empty.
5. Open a terminal and type flac -t <filename.flac>

Actual results:
flac -t filename.flac 

flac 1.3.2
Copyright (C) 2000-2009  Josh Coalson, 2011-2016  Xiph.Org Foundation
flac comes with ABSOLUTELY NO WARRANTY.  This is free software, and you are
welcome to redistribute it under certain conditions.  Type `flac' for details.

filename.flac: *** Got error code 0:FLAC__STREAM_DECODER_ERROR_STATUS_LOST_SYNC

filename.flac: ERROR while decoding data

Expected results:

A proper audiofile with correct meta-information.

Additional info:
I have tested this on several Fedora 26 machine with all the machine the same result. This does not occur in Fedora 25.
Comment 1 Michel Alexandre Salim 2017-09-05 00:19:14 EDT
I experienced the same. The bizarre thing is, this also happens when ripping using Rhythmbox.
Comment 2 Bill Peck 2017-10-30 08:34:43 EDT
I see this issue as well.  Could it be in gstreamer?
Comment 3 Bastien Nocera 2017-11-14 04:28:21 EST
(In reply to Bill Peck from comment #2)
> I see this issue as well.  Could it be in gstreamer?

It is:
Comment 4 Bart Ratgers 2018-02-01 17:25:09 EST
Problem solved.

Note You need to log in before you can comment on or make changes to this bug.