Bug 1480024 - calibre-3.9.0 is available
calibre-3.9.0 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 20:13 EDT by Upstream Release Monitoring
Modified: 2017-11-21 21:26 EST (History)
7 users (show)

See Also:
Fixed In Version: calibre-3.11.1-2.fc27 calibre-3.11.1-1.fc26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-21 18:27:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2017-08-09 20:13:48 EDT
Latest upstream release: 3.6.0
Current version/release in rawhide: 3.4.0-4.fc27
URL: https://calibre-ebook.com/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6141/
Comment 1 Upstream Release Monitoring 2017-09-01 20:13:08 EDT
Latest upstream release: 3.7.0
Current version/release in rawhide: 3.4.0-4.fc27
URL: https://calibre-ebook.com/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6141/
Comment 2 Upstream Release Monitoring 2017-09-22 20:14:14 EDT
Latest upstream release: 3.8.0
Current version/release in rawhide: 3.4.0-4.fc27
URL: https://calibre-ebook.com/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6141/
Comment 3 Hans de Goede 2017-10-17 08:02:48 EDT
Hi,

It would be nice to get a newer calibre into Fedora, because otherwise the kobo plugin will not work with kobo's who have installed the over the air firmware updates.

It would also be good to add the following patch on top of the latest upstream release for current kobo fw support:

https://github.com/kovidgoyal/calibre/commit/37f9ab616ff27daa9ead32d701b1033b8ac6e4ef#diff-474f802d9283d03b3f245ff86c227c35

Regards,

Hans
Comment 4 Kevin Fenzi 2017-10-18 16:59:41 EDT
yes, I'd love to update, but I need python-html5parser at least: 

https://bugzilla.redhat.com/show_bug.cgi?id=1481046

and it's been stalled. Will try and get it moving again.
Comment 5 Hans de Goede 2017-10-19 04:18:24 EDT
(In reply to Kevin Fenzi from comment #4)
> yes, I'd love to update, but I need python-html5parser at least: 
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1481046
> 
> and it's been stalled. Will try and get it moving again.

Ok, can you then perhaps add these 2 commits as patches for now:

https://github.com/kovidgoyal/calibre/commit/15ca24722fd38258dd5752d7917d7d349465ac1d
https://github.com/kovidgoyal/calibre/commit/37f9ab616ff27daa9ead32d701b1033b8ac6e4ef

? That would greatly help kobo users.
Comment 6 Upstream Release Monitoring 2017-10-19 20:12:38 EDT
Latest upstream release: 3.9.0
Current version/release in rawhide: 3.4.0-5.fc28
URL: https://calibre-ebook.com/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6141/
Comment 7 Fedora Update System 2017-10-20 22:44:16 EDT
python-html5-parser-0.4.4-3.fc27 calibre-3.10.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 8 Kevin Fenzi 2017-10-20 23:32:49 EDT
ok, rawhide and f27 should be ok now... f25/f26 will be more difficult. I need a python-lxml update for python-html5-parser. Will look tomorrow...
Comment 9 Fedora Update System 2017-10-21 15:30:01 EDT
calibre-3.10.0-1.fc27, python-html5-parser-0.4.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 10 Fedora Update System 2017-10-23 15:18:14 EDT
calibre-3.10.0-2.fc27 python-html5-parser-0.4.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 11 Hans de Goede 2017-10-24 03:39:13 EDT
(In reply to Kevin Fenzi from comment #8)
> ok, rawhide and f27 should be ok now... f25/f26 will be more difficult. I
> need a python-lxml update for python-html5-parser. Will look tomorrow...

Thank you!
Comment 12 Fedora Update System 2017-10-25 11:22:52 EDT
calibre-3.10.0-2.fc27, python-html5-parser-0.4.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 13 Fedora Update System 2017-11-05 19:00:30 EST
calibre-3.11.1-1.fc27 python-html5-parser-0.4.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 14 Fedora Update System 2017-11-06 16:14:01 EST
calibre-3.11.1-1.fc27, python-html5-parser-0.4.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 15 Fedora Update System 2017-11-06 20:33:43 EST
python-html5-parser-0.4.4-2.fc26 calibre-3.11.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9de839d727
Comment 16 Fedora Update System 2017-11-07 19:07:02 EST
calibre-3.11.1-1.fc26, python-html5-parser-0.4.4-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9de839d727
Comment 17 Fedora Update System 2017-11-08 18:06:12 EST
calibre-3.11.1-2.fc27 python-html5-parser-0.4.4-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 18 Fedora Update System 2017-11-09 14:54:18 EST
calibre-3.11.1-2.fc27, python-html5-parser-0.4.4-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c28e33e56
Comment 19 Fedora Update System 2017-11-21 18:27:50 EST
calibre-3.11.1-2.fc27, python-html5-parser-0.4.4-4.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2017-11-21 21:26:40 EST
calibre-3.11.1-1.fc26, python-html5-parser-0.4.4-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.