Bug 1480039 - Additional HE host deploy fails due to 'received downloaded data size is wrong'
Additional HE host deploy fails due to 'received downloaded data size is wrong'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
4.1.3
Unspecified Linux
medium Severity high
: ovirt-4.2.0
: ---
Assigned To: Simone Tiraboschi
Nikolai Sednev
: Triaged, ZStream
Depends On: 1492157
Blocks: 1493384
  Show dependency treegraph
 
Reported: 2017-08-09 20:45 EDT by Javier Coscia
Modified: 2018-05-15 13:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update fixes an issue where the Manager expects a configuration archive of 20480 bytes but under certain circumstances the size of the configuration archive could be 10240 bytes, causing a failure. The block size is now forced during the archive process, and a file size check is performed.
Story Points: ---
Clone Of:
: 1493384 (view as bug list)
Environment:
Last Closed: 2018-05-15 13:32:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3146551 None None None 2017-08-09 22:09 EDT
oVirt gerrit 81792 master MERGED conf: enforce and check tar archive size 2017-09-20 03:41 EDT
oVirt gerrit 82030 v2.1.z MERGED conf: enforce and check tar archive size 2017-09-20 05:04 EDT
Red Hat Product Errata RHBA-2018:1472 None None None 2018-05-15 13:33 EDT

  None (edit)
Description Javier Coscia 2017-08-09 20:45:43 EDT
Description of problem:

Additional HE host deploy fails and doesn't get deployed as HE, but normal host

Version-Release number of selected component (if applicable):

rhevm-4.1.3.5-0.1.el7.noarch

How reproducible:
100% in customer's environment

Steps to Reproduce:
1. Place host into maintenance
2. Installation > Reinstall > Hosted Engine > Undeploy
3. Installation > Reinstall > Hosted Engine > Deploy

Or 

1. Add a new host > Hosted Engine > Deploy

Actual results:

HE host is being installed as regular host

Expected results:

Host installed as part of the HE cluster

Additional info:
Comment 8 Nikolai Sednev 2017-11-30 10:02:08 EST
Deployed using:
ovirt-hosted-engine-ha-2.2.0-0.0.master.20171128125909.20171128125907.gitfa5daa6.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171129192644.git440040c.el7.centos.noarch
ovirt-engine-appliance-4.2-20171129.1.el7.centos.noarch

Moving to verified.
Comment 11 errata-xmlrpc 2018-05-15 13:32:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1472

Note You need to log in before you can comment on or make changes to this bug.