Bug 1480088 - Links disappear when selecting WebDAV as storage location
Links disappear when selecting WebDAV as storage location
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: deja-dup (Show other bugs)
26
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 02:36 EDT by Kees de Jong
Modified: 2017-08-28 12:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: deja-dup-35.5-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 12:19:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1487772 None None None 2017-08-10 02:36 EDT

  None (edit)
Description Kees de Jong 2017-08-10 02:36:13 EDT
Description of problem: When I type in a link and then select the next input field with either the tab key or with a mouse click, the server address field trims down to what's in front of the colon sign. For example 'https://test.com' would be trimmed down to 'https' only. This makes it impossible to configure the application with WebDAV.


Version-Release number of selected component (if applicable): deja-dup-35.2-1.fc26.x86_64


Steps to Reproduce:
1. Select the WebDAV storage location in the Storage Location tab
2. Type in a link in the server address text field
3. Select 'Use secure connection (HTTPS)'
4. Select another random text field
5. The server address should now be trimmed down to what was in front of the colon sign


Additional info: 
1. Screencast of the issue: https://youtu.be/yN2n1kl1rOo
2. An existing bugreport in Launchpad (I can't sign in there, I get an 'oops' error in both Chrome and Firefox when I try to sign in, no extensions enabled): https://bugs.launchpad.net/deja-dup/+bug/1487772
Comment 1 Gwyn Ciesla 2017-08-16 14:20:44 EDT
Does 35.3 fix this?
Comment 2 Michael Terry 2017-08-16 15:27:56 EDT
Upstream here. I doubt 35.3 does, but upcoming 35.4 probably will.
Comment 3 Gwyn Ciesla 2017-08-18 10:02:04 EDT
I just upgraded to 35.4. Tried it on my local f26 system prior to pushing and building, because:

A. It changed my storage location to Nextcloud
B. It says I don't have duplicity installed.
Comment 4 Michael Terry 2017-08-19 14:14:24 EDT
Thanks for testing, Gwyn!

The new default storage location is Nextcloud (instead of Amazon S3).  Are you saying that your previous non-default location got changed to Nextcloud on you?

It says you don't have duplicity installed...  For context, 35.4 does expand our logic for installing dependencies on the fly.  By default, we only look at whether a package with the name "duplicity" is installed.  But you as a packager can set more.  For example, in ubuntu, I've done the following:

meson builddir -Dgvfs_pkgs=gvfs-backends,python-gi,gir1.2-glib-2.0 \
               -Dboto_pkgs=python-boto \
               -Dcloudfiles_pkgs=python-cloudfiles \
               -Dswiftclient_pkgs=python-swiftclient

You can also pass -Dduplicity_pkgs=... to change which package(s) will install the duplicity program.  Is duplicity not called "duplicity" in Fedora?

Either that's the problem, or our detection (through libpackagekit) isn't working.
Comment 5 Gwyn Ciesla 2017-08-19 15:36:27 EDT
Correct, I'm using ssh.

In Fedora, duplicity is "duplicity".
Comment 6 Michael Terry 2017-08-21 11:08:39 EDT
I haven't been able to reproduce the settings-resetting-to-Nextcloud issue you saw...

But after some testing on Fedora, the "duplicity isn't installed" issue is fixed by:
https://git.launchpad.net/deja-dup/commit/?id=df1765aea7009eb601562eafe5ba15982d109378

Which will be in 35.5 or you can distro patch for the moment.
Comment 7 Gwyn Ciesla 2017-08-22 11:10:17 EDT
I'll wait, the patch doesn't seem to apply to 35.4.
Comment 8 Gwyn Ciesla 2017-08-23 09:57:13 EDT
35.5 looks good.  Thanks!
Comment 9 Fedora Update System 2017-08-23 10:09:10 EDT
deja-dup-35.5-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-23b8313056
Comment 10 Fedora Update System 2017-08-23 21:51:14 EDT
deja-dup-35.5-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-23b8313056
Comment 11 Fedora Update System 2017-08-28 12:19:41 EDT
deja-dup-35.5-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.