Bug 148011 - alsa-utils is missing a buildrequires for gettext-devel
alsa-utils is missing a buildrequires for gettext-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 14:15 EST by Robert Hardy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 09:24:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Hardy 2005-02-14 14:15:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041125 Firefox/1.0

Description of problem:
When attempting to rebuild the recent rawhide alsa-utils the build
fails due to a missing package which is not mentioned as a
buildrequires in the alsa-utils spec file.

Adding gettext-devel to the system allows the build to work.

The alsa-utils spec file should have a buildrequires for gettext-devel.


Version-Release number of selected component (if applicable):
alsa-utils-1.0.8-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e gettext-devel 
2. rpmbuild --target=i686 --rebuild alsa-utils-1.0.8-1.src.rpm
3. build proceeds but fails due to missing gettext-devel.
    

Actual Results:  Build fails with:
+ autoreconf -f -i
/usr/bin/autopoint: line 342: /usr/share/gettext/archive.tar.gz: No
such file or directory
cvs checkout: cannot find module `archive' - ignored
find: archive: No such file or directory
find: archive: No such file or directory
autopoint: *** infrastructure files for version 0.14.1 not found; this
is autopoint from GNU gettext-tools 0.14.1
autopoint: *** Stop.
autoreconf: autopoint failed with exit status: 1
error: Bad exit status from /var/tmp/rpm-tmp.89615 (%build)


Expected Results:  rpm should complain that it needs gettext-devel to
build alsa-utils.


Additional info:

Nothing else is needed.

Note You need to log in before you can comment on or make changes to this bug.