Bug 1480116 - [UI] - UI exception when choosing a disk or pressing on a disk entity
[UI] - UI exception when choosing a disk or pressing on a disk entity
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Daniel Erez
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 04:10 EDT by Michael Burman
Modified: 2017-12-20 06:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:36:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
ui log (1.13 MB, text/plain)
2017-08-10 04:10 EDT, Michael Burman
no flags Details
record (918.10 KB, application/x-gzip)
2017-08-10 04:11 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80438 None None None 2017-08-14 02:20 EDT

  None (edit)
Description Michael Burman 2017-08-10 04:10:28 EDT
Created attachment 1311625 [details]
ui log

Description of problem:
[UI] - UI exception when choosing a disk or pressing on a disk entity 

Go to 'Storage' main tab and then to 'Disks', press on a disk entity and UI exception is thrown - 

2017-08-10 11:06:10,806+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-6) [] Permutation name: ACE2D63A1980E87AF16B317C1BE4C334
2017-08-10 11:06:10,807+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-6) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) : Cannot read property 'nh' of null
        at java.lang.String.join(String.java:123) [rt.jar:1.8.0_131]
        at org.ovirt.engine.ui.uicommonweb.models.disks.DiskGeneralModel.$updateProperties(DiskGeneralModel.java:187)
        at org.ovirt.engine.ui.uicommonweb.models.disks.DiskGeneralModel.onEntityChanged(DiskGeneralModel.java:172)
        at org.ovirt.engine.ui.uicommonweb.models.EntityModel.$setEntity(EntityModel.java:35)
        at org.ovirt.engine.ui.uicommonweb.models.EntityModel.setEntity(EntityModel.java:35)
Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170809175855.git1082d9d.el7.centos

How reproducible:
100%
Comment 1 Michael Burman 2017-08-10 04:11 EDT
Created attachment 1311626 [details]
record
Comment 2 Greg Sheremeta 2017-08-13 18:06:57 EDT
works for me, but assigning to Storage so they can also be sure
Comment 3 Raz Tamir 2017-08-27 04:23:10 EDT
Verified on ovirt-engine-4.2.0-0.0.master.20170826130128.git27024d1.el7.centos

No UI exception is thrown when pressing on disk entity
Comment 4 Sandro Bonazzola 2017-12-20 06:36:56 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.