Bug 1480124 - [RFE] Support Block Provisioner and S3 template deployment via cns-deploy tool
[RFE] Support Block Provisioner and S3 template deployment via cns-deploy tool
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity low
: ---
: CNS 3.6
Assigned To: Jose A. Rivera
Prasanth
:
Depends On: 1488122
Blocks: 1445444
  Show dependency treegraph
 
Reported: 2017-08-10 05:00 EDT by Humble Chirammal
Modified: 2017-10-11 03:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this update, cns-deploy is now able to deploy the gluster-block provisioner pod and the gluster-s3 service pod.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:12:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2881 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-10-11 07:11:43 EDT

  None (edit)
Description Humble Chirammal 2017-08-10 05:00:54 EDT
Description of problem:

At present to deploy gluster block provisioner admin has to do 3 oc commands and 1 command is required to deploy S3 template. 

This RFE is for an enhancement to cns-deploy tool to do it automatically based on some options or switches mentioned by the admin.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 Humble Chirammal 2017-08-10 06:10:00 EDT
https://github.com/gluster/gluster-kubernetes/pull/285
Comment 5 Humble Chirammal 2017-08-29 07:12:45 EDT
https://github.com/gluster/gluster-kubernetes/pull/299 -> S3 deployment.
Comment 9 Prasanth 2017-09-15 13:53:21 EDT
As per the cns-deploy --help output, following are the newly included features/options to the tool as part of this RFE:

*************************************
  --no-block
              Don't deploy a gluster-block container. Default is to deploy.

  --block-host SIZE
              Specify the size (in GB) of the GlusterFS volumes which will be
              automatically created to host gluster-block volumes. Default is
              to not automatically create host volumes for gluster-block.

  --no-object
              Don't deploy a gluster-s3 container. Default is to deploy.

  --object-account ACCOUNT, --object-user USER, --object-password PASSWORD
              Required credentials for deploying the gluster-s3 container. If
              any of these are missing, object container deployment will be
              skipped.

  --object-sc STORAGE_CLASS
              Specify a pre-existing StorageClass to use to create GlusterFS
              volumes to back the object store. Two volumes are created, one
              for object data and one for metadata. Default is to create a new
              StorageClass called 'glusterfs-for-s3'.

  --object-capacity CAPACITY
              The total capacity of the GlusterFS volume which will store the
              object data. Default is '2Gi'.
*************************************

We need to ensure that we are documenting this properly with examples in the appropriate section in the guide.
Comment 11 Prasanth 2017-09-18 08:09:51 EDT
Based on Comment 8, Comment 9 and Comment 10, moving it to Verified.
Comment 13 Ramakrishna Reddy Yekulla 2017-10-04 08:38:35 EDT
I have reviewed the doc text. It looks good to me.
Comment 15 errata-xmlrpc 2017-10-11 03:12:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2881

Note You need to log in before you can comment on or make changes to this bug.