Bug 1480125 - [RFE] Support for auto_unmount option when GlusterFS volumes are mounted.
[RFE] Support for auto_unmount option when GlusterFS volumes are mounted.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: kubernetes (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity low
: ---
: CNS 3.6
Assigned To: Humble Chirammal
Prasanth
:
Depends On: 1424680
Blocks: 1445444
  Show dependency treegraph
 
Reported: 2017-08-10 05:05 EDT by Humble Chirammal
Modified: 2017-10-11 02:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, auto_unmount option is introduced and enabled for gluster mounts in Openshift to ensure that the filesystem is unmounted when a FUSE server is down. When enabled, this option ensures that the filesystem is unmounted by running a separate monitor process.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 02:57:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Humble Chirammal 2017-08-10 05:05:35 EDT
Description of problem:

Latest gluster versions has support for auto_unmount option which helps on gluster volume to be cleanly unmounted if there are some crashes in fuse bridge or main fuse process. The support is available in OCP 3.6 builds, we would like to qualify the same for CNS 3.6.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Humble Chirammal 2017-08-23 08:54:19 EDT
Things to verify:

Actually from OCP/CNS side what we need to verify here is, whenever a mount happens in gluster client, 'auto_unmount' option has been passed to the fuse mounts. From CNS perspective thats the only change we have done. However  with that option in place, if the main fuse process is killed, ideally the unmount of gluster volumes should happen automatically and cleanly. We could check that as well. If this latter functionality doesnt work, its actually a failure on the 'feature' in gluster, but its worth to check. Also we can check the response in app pod when these happens.
Comment 6 Prasanth 2017-09-14 02:43:31 EDT
(In reply to Humble Chirammal from comment #5)
> Things to verify:
> 
> Actually from OCP/CNS side what we need to verify here is, whenever a mount
> happens in gluster client, 'auto_unmount' option has been passed to the fuse
> mounts. From CNS perspective thats the only change we have done. However 
> with that option in place, if the main fuse process is killed, ideally the
> unmount of gluster volumes should happen automatically and cleanly. We could
> check that as well. If this latter functionality doesnt work, its actually a
> failure on the 'feature' in gluster, but its worth to check. Also we can
> check the response in app pod when these happens.

Verified the above and it works as mentioned.
Comment 8 Raghavendra Talur 2017-10-09 06:40:55 EDT
doc text looks good to me
Comment 9 errata-xmlrpc 2017-10-11 02:57:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2878

Note You need to log in before you can comment on or make changes to this bug.