Bug 1480129 - [3.2] "when statements should not include jinja2 templating delimiters" warning is shown when running installer with ansible-2.3.1.0-3.el7.noarch
[3.2] "when statements should not include jinja2 templating delimiters" warni...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.2.1
Unspecified Unspecified
medium Severity low
: ---
: 3.2.1
Assigned To: Russell Teague
Johnny Liu
:
Depends On:
Blocks: 1488359 1488360 1488361 1488363
  Show dependency treegraph
 
Reported: 2017-08-10 05:12 EDT by Johnny Liu
Modified: 2017-10-17 07:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
With Ansible 2.3 warnings are issued when using Jinja delimiters in 'when' conditions. The delimiters have been removed from the code base to avoid these warnings.
Story Points: ---
Clone Of:
: 1488359 1488360 1488361 1488363 (view as bug list)
Environment:
Last Closed: 2017-10-17 07:45:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3.2 installer log (1.84 MB, text/plain)
2017-08-10 05:13 EDT, Johnny Liu
no flags Details

  None (edit)
Description Johnny Liu 2017-08-10 05:12:50 EDT
Description of problem:
When running 3.2 installer with ansible 2.3, a lot of warning is shown up, though it is harmless.


PLAY [Populate config host groups] *********************************************

TASK [fail] ********************************************************************
Thursday 10 August 2017  02:13:09 +0000 (0:00:00.047)       0:00:00.316 ******* 
 [WARNING]: when statements should not include jinja2 templating delimiters
such as {{ }} or {% %}. Found: {{ g_etcd_hosts is not defined }}

Pls search "when statements should not include jinja2 templating delimiters" keyword in the attached installation log to find more.


Version-Release number of the following components:
ansible-2.3.1.0-3.el7.noarch
openshift-ansible-3.2.63-1.git.0.a21de5e.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
a lot of warning is shown after switch ansible version from 2.2 to 2.3

Expected results:
No more warning.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag


Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag
Comment 1 Johnny Liu 2017-08-10 05:13 EDT
Created attachment 1311637 [details]
3.2 installer log
Comment 2 Johnny Liu 2017-08-10 05:59:16 EDT
Other version of installer (3.3 ~ 3.6) also has such issues, but the occurrence is less than 3.2.
Comment 3 Russell Teague 2017-08-24 20:21:25 EDT
Proposed: https://github.com/openshift/openshift-ansible/pull/5207
Comment 4 Russell Teague 2017-08-29 13:12:14 EDT
Merged: https://github.com/openshift/openshift-ansible/pull/5207
Comment 6 Johnny Liu 2017-09-07 03:33:13 EDT
Waiting for newer errata puddle to include the fix.
Comment 7 Johnny Liu 2017-09-14 21:41:25 EDT
No openshift-ansible build is attached to errata, no errata puddle, move it to "MODIFIED"
Comment 9 Johnny Liu 2017-09-18 23:30:04 EDT
Retest this bug with openshift-ansible-3.2.64-1.git.0.fe1fd48.el7, and FAIL.

Still have some warning:
<--snip-->
TASK [openshift_serviceaccounts : Grant the user access to the appropriate scc] ***
Tuesday 19 September 2017  03:03:48 +0000 (0:00:00.514)       0:07:25.184 ***** 
 [WARNING]: when statements should not include jinja2 templating delimiters
such as {{ }} or {% %}. Found: 'system:serviceaccount:{{
openshift_serviceaccounts_namespace }}:{{ item.0 }}' not in {{ (item.1.stdout |
from_yaml).users | default([]) }}
<--snip-->
Comment 10 Russell Teague 2017-09-19 08:25:11 EDT
Proposed: https://github.com/openshift/openshift-ansible/pull/5458
Comment 12 Johnny Liu 2017-09-28 01:34:34 EDT
Verified this bug with openshift-ansible-3.2.65-1.git.0.3e894ed.el7.noarch, and PASS. No WARNING is showing now.
Comment 14 errata-xmlrpc 2017-10-17 07:45:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2900

Note You need to log in before you can comment on or make changes to this bug.