Bug 1480133 - Cloning a VM from template will create the thin-provisioned disk with actual and virtual size the same
Cloning a VM from template will create the thin-provisioned disk with actual ...
Status: CLOSED DUPLICATE of bug 1459455
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Allon Mureinik
Raz Tamir
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 05:39 EDT by Raz Tamir
Modified: 2017-08-10 05:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 05:43:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine and vdsm logs (1.12 MB, application/x-gzip)
2017-08-10 05:39 EDT, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2017-08-10 05:39:10 EDT
Created attachment 1311645 [details]
engine and vdsm logs

Description of problem:
When cloning a VM from template as deep copy, and the image format QCOW2, the actual and the virtual size of the disk will be the same

Creation of the new image:

2017-08-10 12:10:18,138+03 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CreateSnapshotVDSCommand] (default task-7) [vms_create_bf579bb9-64fc-4d0b] START, CreateSnapshotVDSCommand( CreateSnapshotVDSCommandParame
ters:{storagePoolId='dd8c4fca-254c-42f4-a4ea-8ac62d4cf925', ignoreFailoverLimit='false', storageDomainId='1877aa0b-ab8f-41b9-a672-a3063fd1ce41', imageGroupId='d16c4d4c-d2e3-4f7e-b268-9de90ae20322', imageSizeInBytes
='10737418240', volumeFormat='COW', newImageId='2a913ebb-952e-4035-8b18-f81f6182af9c', imageType='Sparse', newImageDescription='null', imageInitialSizeInBytes='9761289310', imageId='00000000-0000-0000-0000-00000000
0000', sourceImageGroupId='00000000-0000-0000-0000-000000000000'}), log id: 5909e6d

The image info from the hsm that copies the data:

2017-08-10 12:10:16,752+0300 INFO  (jsonrpc/1) [vdsm.api] FINISH getVolumeInfo return={'info': {'status': 'OK', 'domain': '1877aa0b-ab8f-41b9-a672-a3063fd1ce41', 'voltype': 'SHARED', 'description': '', 'parent': '00000000-0000-0000-0000-000000000000', 'format': 'COW', 'generation': 0, 'image': '1ad5f4d1-36f4-4dfa-9ae2-1c635b6891d2', 'ctime': '1502277959', 'disktype': '2', 'legality': 'LEGAL', 'mtime': '0', 'apparentsize': '2013265920', 'children': [], 'pool': '', 'capacity': '10737418240', 'uuid': 'f7cfe84c-6cee-40b2-a4ec-4ab1879f5aa2', 'truesize': '2013265920', 'type': 'SPARSE', 'lease': {'owners': [], 'version': None}}} from=::ffff:10.35.162.9,41118, flow_id=vms_create_bf579bb9-64fc-4d0b, task_id=62cc7261-745e-4fd2-8a21-b7dbaf3edc74 (api:52)





Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170808202742.git7c42951.el7.centos.noarch
vdsm-4.20.2-47.gitef4630a.el7.centos.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a VM from template as clone - image format QCOW2
2. Check actual vs. virtual size
3.

Actual results:
The actual and virtual size are the same

Expected results:
The image actual size should be the less that the virtual size

Additional info:
Comment 1 Raz Tamir 2017-08-10 05:43:25 EDT

*** This bug has been marked as a duplicate of bug 1459455 ***

Note You need to log in before you can comment on or make changes to this bug.