Bug 148019 - Kyocera FS1010 ppd file in cups buggy
Kyocera FS1010 ppd file in cups buggy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 16:16 EST by Matthew Cooke
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-12 11:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Cooke 2005-02-14 16:16:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The default ppd file for kyocera FS1010 printer included in cups
doesn't work properly. Some programs won't print at all, some print
garbled postscipt some work unreliably.

A MIT licensed file that does work is here:
http://www.linuxprinting.org/download/PPD/Kyocera/current/English/Kyocera_Mita_FS-1010_English.ppd

This file worked with openoffice and several gnome apps.

The information i found to make the printer work is here:
http://www.linuxprinting.org/kyocera-faq.html

Matt

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.5

How reproducible:
Sometimes

Steps to Reproduce:
1.Attach printer
2.Configure default printer driver
3. try printing from various CUPS compliant apps.
    

Actual Results:  Various:
Somtimes simple files print.
Sometimes you just get a flashing data light on printer.
or garbled output in postscript.
or nothing.

Expected Results:  I would like things to print correctly.

Additional info:

Seems like other people have had similar problems hence the
linuxprinting page.
Comment 1 Tim Waugh 2005-03-30 10:53:35 EST
Is the problem reproducible?  For instance, if a file fails to print and you try
to print it again, will it fail the second time as well?
Comment 2 Matthew Cooke 2005-05-14 16:00:28 EDT
Yes, although it's possible the printer gets into a weird state after the first
attempted print so i normally switched it off and tried again from scratch, this
is particularly true if it prints postscript which also results in it printing
many many pages - in this case I had to switch it off to retry.

Since changing the ppd i haven't had problem with any of the gnome apps or
openoffice.
Comment 3 Matthew Miller 2006-07-10 19:21:08 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 4 Tim Waugh 2006-07-12 11:14:01 EDT
Foomatic now ships with the manufacturer's own PPDs.

Note You need to log in before you can comment on or make changes to this bug.