Bug 1480208 - Dismiss event in Notification Drawer causes Internal server error
Dismiss event in Notification Drawer causes Internal server error
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Eli Mesika
Lucie Leistnerova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 08:15 EDT by Lucie Leistnerova
Modified: 2017-12-20 06:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:37:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
internal_error (57.72 KB, image/png)
2017-08-10 08:15 EDT, Lucie Leistnerova
no flags Details
engine_log (369.10 KB, text/plain)
2017-08-10 08:16 EDT, Lucie Leistnerova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80860 master MERGED core: missing injection caused NPE in event log 2017-08-22 04:16 EDT

  None (edit)
Description Lucie Leistnerova 2017-08-10 08:15:21 EDT
Created attachment 1311723 [details]
internal_error

Description of problem:
When removing events in Notification Drawer after some time already dismissed events appear back and they can't be removed.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170809175855.git1082d9d.el7.centos.noarch

How reproducible: reproduced in two newest 4.2 engines, not in older one


Steps to Reproduce:
1. go to Events and Alerts notifications in top right menu
2. expand Events
3. repeatedly dismiss the first showed event until error appears

Actual results: Error while executing action RemoveAuditLogById: Internal Engine Error, see attachment


Expected results: no error and event is dismissed
Comment 1 Lucie Leistnerova 2017-08-10 08:16 EDT
Created attachment 1311724 [details]
engine_log
Comment 2 Greg Sheremeta 2017-08-13 17:59:52 EDT
Looks to be a backend error, and we (UX) haven't done any changes here lately. Therefore assigning to infra.
Comment 3 Eli Mesika 2017-08-17 07:38:22 EDT
Unable to reproduce on master 

Have created DC / Cluster / Host and removed events during host installation , worked for me 

Please provide exact scenario to reproduce including the exact amount of time you wait to get 6the dismissed event back and which kind of events were produced and dismissed
Comment 4 Lucie Leistnerova 2017-08-21 04:09:23 EDT
It could have something to do only with error messages.

Steps to reproduce:
1. try to add 4.1 host to 4.2 cluster
2. incompatible error appears in events
4. go to Events from left menu
5. open Notifications, go to Events tab and dismiss this error (most likely you have to dismiss some info events until this error appears)
6. error disappears from notifications but stays in Events
7. dismiss info events until the error appears again
8. try to dismiss this error

Sometimes the internal error is shown at the first dismiss of this error event. Maybe when is there other error event (e.g. ETL service sampling).

Always new error in events appears "User admin@internal-authz failed to remove event list message XX." and this one can't be then dismissed too.
Comment 5 Lucie Leistnerova 2017-09-01 06:18:19 EDT
no Internal error appeared

verified in ovirt-engine-4.2.0-0.0.master.20170831223128.git34f4d69.el7.centos.noarch
Comment 6 Sandro Bonazzola 2017-12-20 06:37:21 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.