Bug 1480213 - SSH public key field not shown when adding a host
SSH public key field not shown when adding a host
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
4.1.3.5
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Scott Dickerson
samuel macko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 08:18 EDT by Fabrice Bacchella
Modified: 2017-12-20 06:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:45:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
sdickers: devel_ack+


Attachments (Terms of Use)
On Safari (9.44 KB, image/png)
2017-08-10 08:18 EDT, Fabrice Bacchella
no flags Details
On Firefix (12.69 KB, image/png)
2017-08-10 08:19 EDT, Fabrice Bacchella
no flags Details
On Chrome (16.31 KB, image/png)
2017-08-10 08:19 EDT, Fabrice Bacchella
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 83147 master MERGED webadmin: fix SSH public key field visibility toggle in Safari 2017-10-24 18:37 EDT

  None (edit)
Description Fabrice Bacchella 2017-08-10 08:18:54 EDT
Created attachment 1311728 [details]
On Safari

Only chrome can show the root ssh public key when configuring the root authentication of a new host.
Comment 1 Fabrice Bacchella 2017-08-10 08:19 EDT
Created attachment 1311729 [details]
On Firefix
Comment 2 Fabrice Bacchella 2017-08-10 08:19 EDT
Created attachment 1311731 [details]
On Chrome
Comment 3 Oved Ourfali 2017-08-29 08:27:11 EDT
Ravi, can you please take a look?
Comment 4 Martin Perina 2017-08-30 07:15:34 EDT
I'm not able to reproduce this issue with latest oVirt 4.1.6 RC1 build. I've tested Firefox 52.3.0 and Chrome 60.0.3112.113 and on both browsers the SSH Public Key field is displayed properly.

Could you please try to clear your cache and check again? If it doesn't help, could you please try to upgrade engine to latest 4.1.z version?
Comment 5 Fabrice Bacchella 2017-08-31 12:29:41 EDT
This bug is here from at least 3.6. So I don't think it's a clean cache problem. But I'm on mac os, it might be related. But it's still strange that it shows on FF too.
Comment 6 Pavel Stehlik 2017-10-24 06:24:09 EDT
Indeed: 4.1.7

<div class="form-group" title="For allowing PK authentication, copy the following PK to host under /root/.ssh/authorized_keys" style="visibility: hidden"><label class="control-label labelEnabled" for="HostPopupView_publicKey" style="display: none;" aria-hidden="true"></label><div><div class="GKIIXFICK-B"><textarea style="border-width: 0px;" id="HostPopupView_publicKey" class="form-control form-control-readonly" readonly="" tabindex="15"></textarea></div></div><div class="GKIIXFICH-B"></div></div>

note the "hidden" - once I removed it, it's shown. 

Chrome probably doesn't respect that element, thus is only which shows it.
(Safari nor FF 55.0.3 - don't show).
Comment 7 Martin Perina 2017-10-24 06:27:20 EDT
Greg, could someone from UX team a look, why this issue exists on MacOS? As it works fine on Linux as mentioned in Comment 4
Comment 8 Scott Dickerson 2017-10-24 11:59:59 EDT
The visibility style on the form-group holding the ssh public key field wasn't being changed when the radio buttons were clicked, but only in Safari.  Patch addresses 2 potential issues:
   1. directly changing the style vs standard #setVisibility()
   2. change from onFocus to onClick for the event handlers on the 
      password and ssh public key radio buttons
Comment 9 samuel macko 2017-12-08 07:09:27 EST
Verified in RHVM version 4.2.0-0.6.el7 on Firefox 57.0.

Verified by following the reproducer.
Comment 10 Sandro Bonazzola 2017-12-20 06:45:36 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.