Bug 1480228 - heketi has a dangling entry of gluster-block device
heketi has a dangling entry of gluster-block device
Status: CLOSED DUPLICATE of bug 1479777
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Adam
Anoop
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 08:37 EDT by krishnaram Karthick
Modified: 2017-08-11 17:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 17:15:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnaram Karthick 2017-08-10 08:37:43 EDT
Description of problem:
On a fresh CNS setup, a block device was created and deleted. 

sequence of steps:

[root@dhcp47-10 ~]# heketi-cli blockvolume create --size=1
Name: blockvol_fe101c6ebe284a3541ee55fd27455679
Size: 1
Volume Id: fe101c6ebe284a3541ee55fd27455679
Cluster Id: ec2643d674d0c508a7bfaf8f8def2cf1
Hosts: [10.70.46.248 10.70.47.49 10.70.47.72]
IQN: iqn.2016-12.org.gluster-block:c6e412b5-c570-4686-a691-514643a11bbf
LUN: 0
Hacount: 3
Username:
Password:
Block Hosting Volume: e35289f5c42657c03386ecaa569b8659
[root@dhcp47-10 ~]#
[root@dhcp47-10 ~]#
[root@dhcp47-10 ~]# heketi-cli blockdevice delete fe101c6ebe284a3541ee55fd27455679
Error: unknown command "blockdevice" for "heketi-cli"
Run 'heketi-cli --help' for usage.
[root@dhcp47-10 ~]# heketi-cli blockvolume delete fe101c6ebe284a3541ee55fd27455679
Error: Unable to get the block volume delete info for block volume blockvol_fe101c6ebe284a3541ee55fd27455679
[root@dhcp47-10 ~]# heketi-cli blockvolume info blockvol_fe101c6ebe284a3541ee55fd27455679
Error: Invalid path or request

[root@dhcp47-10 ~]# heketi-cli blockvolume info fe101c6ebe284a3541ee55fd27455679
Name: blockvol_fe101c6ebe284a3541ee55fd27455679
Size: 1
Volume Id: fe101c6ebe284a3541ee55fd27455679
Cluster Id: ec2643d674d0c508a7bfaf8f8def2cf1
Hosts: [10.70.46.248 10.70.47.49 10.70.47.72]
IQN: iqn.2016-12.org.gluster-block:c6e412b5-c570-4686-a691-514643a11bbf
LUN: 0
Hacount: 3
Username:
Password:
Block Hosting Volume: e35289f5c42657c03386ecaa569b8659

[root@dhcp47-10 ~]# heketi-cli blockvolume delete fe101c6ebe284a3541ee55fd27455679
Error: Unable to execute command on glusterfs-gs6n5:

When I check in the backend, there is no block-volume. So, heketi has actually deleted in the first attempt but failed to update its db accordingly. [check heketi-log that'll be attached shortly]


sh-4.2# gluster-block volume list
unknown option: volume
sh-4.2# gluster vol list
heketidbstorage
vol_e35289f5c42657c03386ecaa569b8659
sh-4.2# gluster-block list  vol_e35289f5c42657c03386ecaa569b8659
*Nil*

Version-Release number of selected component (if applicable):
cns-deploy-5.0.0-14.el7rhgs.x86_64

How reproducible:
1/1

Steps to Reproduce:
create and delete gluster-block vol via heketi
Comment 3 Mohamed Ashiq 2017-08-11 17:15:15 EDT
Please reopen if this is not the duplicate.

*** This bug has been marked as a duplicate of bug 1479777 ***

Note You need to log in before you can comment on or make changes to this bug.