Bug 1480235 - Remote Execution Job runs multiple times on Hosts with more than one Interface
Remote Execution Job runs multiple times on Hosts with more than one Interface
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution (Show other bugs)
6.2.10
x86_64 Linux
unspecified Severity medium (vote)
: 6.2.12
: --
Assigned To: satellite6-bugs
Peter Ondrejka
: Triaged
Depends On: 1478878
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 09:11 EDT by Evgeni Golov
Modified: 2017-09-25 14:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: rubygem-foreman_remote_execution-0.3.0.19-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1478878
Environment:
Last Closed: 2017-09-25 14:59:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screeenshot (19.38 KB, image/png)
2017-08-28 11:58 EDT, Peter Ondrejka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20260 None None None 2017-08-17 09:40 EDT

  None (edit)
Comment 1 Evgeni Golov 2017-08-10 09:12:52 EDT
This is literally a one-word fix, which I would love to propose for 6.2.z
Comment 6 Ivan Necas 2017-08-17 09:40:45 EDT
I believe the fix for http://projects.theforeman.org/issues/20260 will also resolve this issue. Assigning to the POST instead of marking as duplicate, to have this case covered by QE verification.
Comment 8 Peter Ondrejka 2017-08-28 11:58 EDT
Created attachment 1319140 [details]
screeenshot

Verified on satellite-6.2.12-1.0.el6sat.noarch, rex job is executed just once on host collection member with several interfaces.
Comment 10 errata-xmlrpc 2017-09-25 14:59:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803

Note You need to log in before you can comment on or make changes to this bug.