Bug 1480264 - rebase dbus to latest stable upstream version
Summary: rebase dbus to latest stable upstream version
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dbus   
(Show other bugs)
Version: 7.5
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
Jana Heves
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks: 1420851 1479818 1460262 1531148
TreeView+ depends on / blocked
 
Reported: 2017-08-10 14:29 UTC by Tomas Pelka
Modified: 2018-04-10 12:54 UTC (History)
6 users (show)

Fixed In Version: dbus-1.10.24-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_dbus_ rebased to version 1.10 The _dbus_ packages have been upgraded to upstream version 1.10, which provides a number of bug fixes and enhancements over the previous version. Notable changes include: * *dbus-run-session* is a new utility to run a *dbus* session bus for the runtime of a login session, making *ssh* sessions which start dbus-using applications more predictable and reliable. See `man 1 dbus-run-session` for more details. * Several memory and file descriptor leaks have been fixed. This improves the *dbus-daemon* memory usage and reliability. * The well-known system and session bus configuration files have been moved from `/etc/dbus-1/` to the `/usr/share/dbus-1/` directory. While the old location can still be used, it is deprecated (specifically, `session.conf` and `system.conf` are deprecated, but system administrator configuration snippets under `session.d` and `system.d` are permitted).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 12:52:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0765 None None None 2018-04-10 12:54 UTC
Red Hat Bugzilla 1536352 None CLOSED Automatic Provides added libdbus-1.so.3(LIBDBUS_1_3)(64bit) to libdbus-1.so.3()(64bit) for dbus-libs, meaning the packag... 2019-01-30 11:17 UTC

Description Tomas Pelka 2017-08-10 14:29:21 UTC
Description of problem:
Current stable version of dbus is 1.10, rhel7 contains 1.6 which is quite old and might be a good idea to rebase to newer version. It will resolve couple of issues and also contains lots of misc leak fixes and generaly improvements

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 11 Jan Pokorný [poki] 2018-01-19 08:38:21 UTC
The rebase may indirectly contribute to system-wide regression wrt.
easy down-/up-gradeability: [bug 1536352]

Comment 14 errata-xmlrpc 2018-04-10 12:52:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0765


Note You need to log in before you can comment on or make changes to this bug.