Bug 1480336 - Document IAM permissions required for AWS integration PR 1802
Document IAM permissions required for AWS integration PR 1802
Status: CLOSED DUPLICATE of bug 1426755
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 14:31 EDT by Michael Burke
Modified: 2017-09-20 02:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-20 02:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Burke 2017-08-10 14:31:03 EDT
PR 1402: https://github.com/openshift/openshift-docs/issues/1802

Upstream Doc: Identity and Access Management 
https://github.com/kubernetes/kubernetes/blob/8cc91944e0555af82f86cc7f21fb638be60665fd/docs/design/aws_under_the_hood.md#identity-and-access-management-iam

Upstream has provided IAM policies required for masters and minions which we should document along with AWS configuration.

For demo-ansible, we are using the following policies:

Nodes

{
    "Statement":[
    {
        "Resource":"*",
        "Action":"ec2:Describe*",
        "Effect":"Allow"
    },
    {
        "Resource":"*",
        "Action":"ec2:AttachVolume",
        "Effect":"Allow"
    },
    {
        "Resource":"*",
        "Action":"ec2:DetachVolume",
        "Effect":"Allow"
    }
    ],
    "Version":"2012-10-17"
}

Masters

{
    "Statement":[
    {
        "Resource":"*",
        "Action":"ec2:*",
        "Effect":"Allow"
    },
    {
        "Resource":"*",
        "Action":"elasticloadbalancing:*",
    

    "Effect":"Allow"
    }
    ],
    "Version":"2012-10-17"
}
Comment 1 Vikram Goyal 2017-09-20 02:38:49 EDT

*** This bug has been marked as a duplicate of bug 1426755 ***

Note You need to log in before you can comment on or make changes to this bug.