Bug 148034 - Severe X resource leak from gimp
Summary: Severe X resource leak from gimp
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-15 00:50 UTC by John William
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 14:29:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John William 2005-02-15 00:50:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
Q312461)

Description of problem:
There appears to be a severe X resource leak in the Gimp. When 
creating an HSV graph, the X memory footprint goes from around 90M 
virtual to over 400M in about 30 seconds.

On the 256MB machine where I first noticed this, the machine started 
page thrashing so badly it needed to be hard reset (probably worth a 
kernel bug report there). On a bigger memory machine that can 
survive, the X server does not appear to release the memory even 
after the Gimp exits - but I'm still assuming that the root of the 
problem is a resource leak in the Gimp.

Version-Release number of selected component (if applicable):
gimp-2.2.3-0.fc3.2

How reproducible:
Always

Steps to Reproduce:
1. Open Gimp.
2. Create new image. I used 640x480 RGB.
3. Go to Script-Fu -> Util -> Draw HSV Graph... and OK with default 
parameters.


Actual Results:  The Gimp chugs along and the X server's memory 
baloons wildly.

Expected Results:  Drawing the HSV graph should not cause X server 
resources to baloon out of control.

Additional info:

Machine is up-to-date FC3, with:

kernel-2.6.10-1.760_FC3
xorg-x11-6.8.1-12.FC3.21

The machine is using the X.org "nv" driver for a GeForce4 Ti4200 card 
(128MB).

I marked the severity high because the leak is so severe - on a lower 
memory machine, it can push the machine into uncontrollable page 
thrashing and effectively freeze the machine solid after 30-45 
seconds.

Comment 1 Nils Philippsen 2006-04-05 14:29:15 UTC
I just tried this with a 1766 x 1428 pixels big image on FC5 and both gimp
(gimp-2.2.10-4) and Xorg (xorg-x11-server-Xorg-1.0.1-9) had a constant, low (73M
and 36M RSS respectively) memory consumption, so I consider this fixed.


Note You need to log in before you can comment on or make changes to this bug.