Bug 1480433 - [RFE] Indicate host needs to be reinstalled to push new configurations.
Summary: [RFE] Indicate host needs to be reinstalled to push new configurations.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ravi Nori
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1489902 (view as bug list)
Depends On:
Blocks: 1501793
TreeView+ depends on / blocked
 
Reported: 2017-08-11 05:47 UTC by Germano Veit Michel
Modified: 2021-05-01 16:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
A host must be reinstalled if you turn Kdump integration on or off, or change the kernel command line parameters. All hosts in a cluster must be reinstalled if you change the firewall type of the cluster. An exclamation mark icon in Compute > Hosts indicates that a host needs to be reinstalled. Details appear in the host's details view, in the Events tab.
Clone Of:
: 1501793 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:43:37 UTC
oVirt Team: Infra
Target Upstream Version:
pmatyas: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 389873 0 None None None 2017-09-11 07:35:39 UTC
Red Hat Knowledge Base (Solution) 1360383 0 None None None 2017-08-11 06:16:53 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:45:35 UTC
oVirt gerrit 82121 0 master MERGED engine : Indicate host needs to be reinstalled to push new configurations 2020-09-15 08:38:00 UTC
oVirt gerrit 83779 0 master MERGED webadmin: Add host reinstall needed text in hosts details view 2020-09-15 08:37:59 UTC
oVirt gerrit 84464 0 master MERGED engine : Show notification when kdump is disable after fresh install 2020-09-15 08:37:59 UTC

Description Germano Veit Michel 2017-08-11 05:47:03 UTC
Description of problem:

For VMs, if the user changes a configuration that requires the VM to be power cycled to take effect, a tooltip is displayed to inform the user.

However, the same applies for Hosts but and there is no such feature.
Some host configurations require the host to be re-installed in order to be pushed. One example is kdump integration. We have the following note in the 

Documentation:
~~~
When you enable Kdump integration on an existing host, the host must be reinstalled for kdump to be configured. See Section 7.5.12, “Reinstalling Hosts”. 
~~~

This is not user-friendly. This RFE is to create a similar feature for Hosts.

Comment 2 Marina Kalinin 2017-09-08 20:39:56 UTC

*** This bug has been marked as a duplicate of bug 1489902 ***

Comment 3 Martin Perina 2017-09-11 07:35:40 UTC
There are other options which require host reinstallation such as changing kernel command line parameters of the host or changing type of firewall for the cluster, so I'm reopening this RFE to cover all existing scenarios

Comment 4 Martin Perina 2017-09-11 07:42:05 UTC
*** Bug 1489902 has been marked as a duplicate of this bug. ***

Comment 5 Martin Perina 2017-09-11 19:40:18 UTC
Marina, this is not a bug, this is RFE, because all such changes either shows that somehow or the need to reinstall is described in documentation.

Also we are still looking at the scope we don't know yet if we will backport it to 4.1.z. Let's work on it for 4.2 and when done we will see.

Comment 10 Petr Matyáš 2017-11-06 16:33:30 UTC
Exclamation mark is displayed, but no particular error/warning is shown anywhere, I would expect some text in hosts detail view.

Using version ovirt-engine-4.2.0-0.0.master.20171105155215.git59d3324.el7.centos.noarch

Comment 12 Red Hat Bugzilla Rules Engine 2017-11-21 17:00:30 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 13 Red Hat Bugzilla Rules Engine 2017-11-21 18:47:39 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 14 Red Hat Bugzilla Rules Engine 2017-11-21 18:49:15 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 16 Petr Matyáš 2017-12-11 12:20:46 UTC
Verified on ovirt-engine-4.2.0-0.6.el7.noarch

Comment 20 errata-xmlrpc 2018-05-15 17:43:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 21 Franta Kust 2019-05-16 13:03:18 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.