Bug 1480445 - Log entry of files skipped/failed during rebalance operation
Log entry of files skipped/failed during rebalance operation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Nithya Balachandran
: FutureFeature, ZStream
Depends On:
Blocks: 1463114 1531936 1486557
  Show dependency treegraph
 
Reported: 2017-08-11 02:34 EDT by Nithya Balachandran
Modified: 2018-01-06 13:36 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.13.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1463114
: 1486557 (view as bug list)
Environment:
Last Closed: 2017-12-08 12:37:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2017-08-11 02:34:14 EDT
+++ This bug was initially created as a clone of Bug #1463114 +++

Description of problem:

As of now rebalance status just indicate the count of failed and skipped entries. This information should be more informative and should even give the list of files so that list can be used to manually operate and complete rebalancing.



  Good to have list of files in a separate log file. Preferable would be to have file path and not gfid. 
   We should log in such a way that it can be consumed easily even if the list is long.
   With this fix we should even create a way/script to consume the list and make the life of Admin easier. As of now doing it manually is a tough job.

So here we have 3 requirements :
   1) Get the list of files failed or skipped with error messages
   2) Automatically consume those file list to complete rebalance( This can be triggered manually)
   3) If not able to consume list, list the file with some reason of failure
Comment 1 Nithya Balachandran 2017-08-11 02:44:32 EDT
Skipped files are now logged in the rebalance log :

2017-08-11 05:33:01.464620] I [MSGID: 109126] [dht-rebalance.c:2681:gf_defrag_migrate_single_file] 0-vol1-dht: File migration skipped for /NEWFILE-1.


Users can search for the msgid [109126] for the list of skipped files.
Comment 2 Worker Ant 2017-08-11 02:50:34 EDT
REVIEW: https://review.gluster.org/18021 (cluster/dht:  Log files skipped by rebalance) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 3 Worker Ant 2017-08-30 01:56:19 EDT
COMMIT: https://review.gluster.org/18021 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a4c43ba9374b8f75a48d38a032353a0c7d311a73
Author: N Balachandran <nbalacha@redhat.com>
Date:   Fri Aug 11 12:16:12 2017 +0530

    cluster/dht:  Log files skipped by rebalance
    
    There was no easy way to find out which files were
    skipped during a rebalance.
    Rebalance now logs a message for every skipped file
    using msgid 109126, making it easier to find
    all files that were skipped.
    
    Change-Id: I2cac7db7285e2f82354251f3ea4094827b0daf3e
    BUG: 1480445
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: https://review.gluster.org/18021
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: hari gowtham <hari.gowtham005@gmail.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Shyamsundar 2017-12-08 12:37:20 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.