Bug 1480488 - module streams with enabled/disabled and list
module streams with enabled/disabled and list
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks: dnf-modularity
  Show dependency treegraph
 
Reported: 2017-08-11 05:02 EDT by Irina Gulina
Modified: 2017-08-14 03:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 03:32:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nodejs streams (8.06 KB, text/plain)
2017-08-11 05:02 EDT, Irina Gulina
no flags Details

  None (edit)
Description Irina Gulina 2017-08-11 05:02:48 EDT
Created attachment 1312041 [details]
nodejs streams

Description of problem:

I'm not sure what is wrong here, but the following behavior seems to be odd to me. 

1) `dnf module list --disabled`. Notice there are two `nodejs`, one is from f26 stream, another - 8 stream. 
2) `dnf module enable nodejs`
3) `dnf module list --disabled`. Notice there is no any `nodejs`
4) `dnf module list --enabled`. Notice only one `nodejs`

Where is the second one? 


Version-Release number of selected component (if applicable):
latest boltron compose 07-17
dnf-2.6.0-3.git.40.c0f7fc6.module_a7788b02.noarch

How reproducible:
always
Comment 1 Martin Hatina 2017-08-14 03:32:46 EDT
Fixed in https://copr.fedorainfracloud.org/coprs/mhatina/DNF-Modules

Note You need to log in before you can comment on or make changes to this bug.