Bug 1480491 - tests: Enable geo-rep test cases
tests: Enable geo-rep test cases
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-11 05:08 EDT by Kotresh HR
Modified: 2018-03-15 07:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-15 07:17:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2017-08-11 05:08:18 EDT
Description of problem:
Enable geo-rep test cases

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-08-11 05:24:38 EDT
REVIEW: https://review.gluster.org/18024 (tests: Remove sleeps in geo-rep test cases) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 2 Worker Ant 2017-08-11 05:31:37 EDT
REVIEW: https://review.gluster.org/18024 (tests: Remove sleeps in geo-rep test cases) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 3 Worker Ant 2017-08-11 08:55:30 EDT
REVIEW: https://review.gluster.org/18024 (tests: Remove sleeps in geo-rep test cases) posted (#3) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 4 Worker Ant 2018-01-05 02:08:37 EST
COMMIT: https://review.gluster.org/18024 committed in master by \"Kotresh HR\" <khiremat@redhat.com> with a commit message- tests: Enable geo-rep test cases

This patch re-enables the geo-rep test cases.
Along with it does following optimizations.

1. Use EXPECT_WITHIN instead of sleep
2. Clean up geo-rep ssh key after test
3. Changes to gverify.sh and S56glusterd-geo-rep-create-post.sh
   to use the given ssh identity file for geo-rep create
4. Make gluster-command-dir configurable and introduce
   slave-gluster-command-dir which points the parent directory
   of gluster binaries in master and slave respectively.

Change-Id: Ia7696278d9dd3ba04224dcd7c3564088ca970b04
BUG: 1480491
Signed-off-by: Kotresh HR <khiremat@redhat.com>
Comment 5 Shyamsundar 2018-03-15 07:17:56 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.