Bug 1480561 - Organization Admin roles doesnt have permissions for Access Insights
Organization Admin roles doesnt have permissions for Access Insights
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: satellite6-bugs
Jitendra Yejare
: Triaged
Depends On:
Blocks: 1373844
  Show dependency treegraph
 
Reported: 2017-08-11 07:52 EDT by Jitendra Yejare
Modified: 2017-12-13 08:45 EST (History)
4 users (show)

See Also:
Fixed In Version: rubygem-foreman-redhat_access-2.0.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 08:45:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Attached (29.66 KB, image/png)
2017-08-11 07:56 EDT, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github redhataccess/foreman-plugin/pull/11 None None None 2017-08-14 02:35 EDT

  None (edit)
Description Jitendra Yejare 2017-08-11 07:52:15 EDT
Description of problem:
The Organization admin role doesn't have permissions for Access Insights.
When I login with Organization Admin in satellite it doesn't display menu for Access Insights.

Version-Release number of selected component (if applicable):
Satellite 6.3 snap 11

How reproducible:
Always

Steps to Reproduce:
1. Create org admin role by cloning Organization Admin default role
2. Create new user and assign above cloned role
3. Login with new user in satellite

Actual results:
For org admin user, The Access Insights menu isn't displayed

Expected results:
Org Admin should have permissions to Access Insights

Additional info:
Comment 2 Jitendra Yejare 2017-08-11 07:56 EDT
Created attachment 1312104 [details]
Screenshot Attached
Comment 3 Marek Hulan 2017-08-11 09:12:15 EDT
The gem needs to use the macro "add_all_permissions_to_default_roles" to extend permissions. Please ping me if you need more info.
Comment 4 Marek Hulan 2017-08-11 09:28:02 EDT
Sent a fix to https://github.com/redhataccess/foreman-plugin/pull/11
Comment 9 Jitendra Yejare 2017-08-28 09:06:23 EDT
Verified!

Satellite 6.3.0 snap 13

Steps:
1. Created org admin role by cloning Organization Admin default role
2. Created new user and assigned above cloned role
3. Login with new user in satellite

Actual results:
For org admin user, The Access Insights, Red Hat Acess menu is displayed.


Note:

I see some weird behavior while logged in as org Admin, that the Red hat access login dialog keep on refreshes and throws warning message of already logged in.
Bug is logged here : https://bugzilla.redhat.com/show_bug.cgi?id=1485929 
But the issue is out of scope for this bug. So verifying this bug.

Note You need to log in before you can comment on or make changes to this bug.