Bug 1480595 - Error on visiting the show guide button for oscap policy
Error on visiting the show guide button for oscap policy
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.3.1
: --
Assigned To: Marek Hulan
Sanket Jagtap
: Regression, Triaged
Depends On: 1502001 1545584
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-11 08:48 EDT by Sanket Jagtap
Modified: 2018-04-22 17:34 EDT (History)
12 users (show)

See Also:
Fixed In Version: foreman_openscap 0.7.6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-13 09:29:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error (150.72 KB, image/png)
2017-08-11 08:48 EDT, Sanket Jagtap
no flags Details
screenshot of UI (28.91 KB, image/png)
2017-09-17 08:57 EDT, Nikhil Kathole
no flags Details
log in production.log file (18.30 KB, text/plain)
2017-09-17 08:58 EDT, Nikhil Kathole
no flags Details
guide page (155.27 KB, image/png)
2018-01-31 07:10 EST, Sanket Jagtap
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20599 None None None 2017-08-14 16:11 EDT
Red Hat Knowledge Base (Article) 3420661 None None None 2018-04-22 17:34 EDT
Red Hat Product Errata RHBA-2018:1126 None None None 2018-04-13 09:31 EDT

  None (edit)
Description Sanket Jagtap 2017-08-11 08:48:58 EDT
Created attachment 1312123 [details]
Error

Description of problem:


Version-Release number of selected component (if applicable):
Satellite 6.3.0 snap 10

How reproducible:


Steps to Reproduce:
1.Create a oscap Policy 
2.Click on the show guide button , on the policy page
3.

Actual results:
Oops, we're sorry but something went wrong undefined method `h' for #<ForemanOpenscap::Policy:0x007f1469c92848>

Expected results:
No error, guide should be displayed

Additional info:
Comment 2 Marek Hulan 2017-08-11 09:47:16 EDT
Sanket, could you please upload the production.log? The trace would help greatly.
Comment 3 Marek Hulan 2017-08-14 16:10:05 EDT
Ah, Sanket uploaded the trace in png, next time please copy it from production log, it helps copying paths :-)

Anyway it's clear that it was caused by rubocop fixes that automatically added h method to model where it's unavailable.
Comment 4 Marek Hulan 2017-08-14 16:11:47 EDT
Created redmine issue http://projects.theforeman.org/issues/20599 from this bug
Comment 5 pm-sat@redhat.com 2017-08-14 18:06:38 EDT
Upstream bug assigned to mhulan@redhat.com
Comment 6 pm-sat@redhat.com 2017-08-14 18:06:41 EDT
Upstream bug assigned to mhulan@redhat.com
Comment 8 pm-sat@redhat.com 2017-09-14 08:06:15 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20599 has been resolved.
Comment 9 Nikhil Kathole 2017-09-17 08:57:08 EDT
FailedQA

Version Tested:
Satellite-6.3 Snap 16

steps:
1. Created policy
2. Clicked on show guide button

Clicking on show guide button shows 500 Internal server error.
Comment 10 Nikhil Kathole 2017-09-17 08:57 EDT
Created attachment 1326957 [details]
screenshot of UI
Comment 11 Nikhil Kathole 2017-09-17 08:58 EDT
Created attachment 1326958 [details]
log in production.log file
Comment 12 Marek Hulan 2017-09-18 04:54:12 EDT
Nikhil, this is most likely caused by the issue in openscap package. Seems like http://projects.theforeman.org/issues/17839. Please verify version of openscap on you capsule

rpm -q openscap

if it's lower than 1.2.15, please upgrade it first. That's not a bug in Satellite. Otherwise please provide capsule logs.
Comment 13 Nikhil Kathole 2017-09-18 06:07:25 EDT
Marek, I found openscap-1.2.14 version for latest rhel 7.4. So as dependency is from rhel base OS, we can't verify this bug unless we get 1.2.15 version in rhel. 

# rpm -q openscap
openscap-1.2.14-2.el7.x86_64

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.4 (Maipo)
Comment 14 Marek Hulan 2017-09-18 06:23:12 EDT
I agree that you can't verify this, but I don't think it should be considered FailedQA. I suggest you move it back to ON_QA. For the reference, this is an upstream fix in openscap project https://github.com/OpenSCAP/openscap/pull/745. You can file a bug against RHEL and set it as a blocker for this.
Comment 15 Nikhil Kathole 2017-09-18 06:35:52 EDT
Moving this back to ON_QA...will verify this with openscap-1.2.15.
Comment 17 Sanket Jagtap 2018-01-31 07:10 EST
Created attachment 1388935 [details]
guide page
Comment 21 Sanket Jagtap 2018-02-14 06:28:02 EST
Moving the bug to ON_QA , because on the latest brew build for 7.4 zstream from comment #18 is still able to reproduce the issue.
Comment 32 Mike McCune 2018-03-09 13:10:13 EST
Sanket, is this VERIFIED then? if so, we can close this out as CLOSED:CURRENTRELEASE
Comment 33 Sanket Jagtap 2018-03-09 13:36:20 EST
Yes , this is verified with the build shipped with 7.4.5
Comment 35 errata-xmlrpc 2018-04-13 09:29:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1126

Note You need to log in before you can comment on or make changes to this bug.