Bug 1480694 - Custom Repositories built with SHA1 checksums produce incorrect SHA256 repodata [NEEDINFO]
Custom Repositories built with SHA1 checksums produce incorrect SHA256 repodata
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.2.10
Unspecified Unspecified
medium Severity urgent (vote)
: 6.2.15
: --
Assigned To: satellite6-bugs
jcallaha
: PrioBumpGSS, Triaged
Depends On: 1466950
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-11 13:43 EDT by Justin Sherrill
Modified: 2018-05-21 16:17 EDT (History)
14 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.169-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1466950
Environment:
Last Closed: 2018-05-21 16:16:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bhoefer: needinfo? (zhunting)


Attachments (Terms of Use)
el6 hotfix (8.14 MB, application/x-tar)
2017-08-16 09:55 EDT, Justin Sherrill
no flags Details
el7 hotfix (7.55 MB, application/x-tar)
2017-08-16 09:56 EDT, Justin Sherrill
no flags Details
RHEL7 Hotfix for Sat 6.2.14 (7.56 MB, application/x-tar)
2018-02-13 17:00 EST, Brad Buckingham
no flags Details
RHEL6 Hotfix for Sat 6.2.14 (8.15 MB, application/x-tar)
2018-02-13 17:01 EST, Brad Buckingham
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1672 None None None 2018-05-21 16:17 EDT

  None (edit)
Comment 2 pulp-infra@redhat.com 2017-08-11 16:34:44 EDT
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 3 pulp-infra@redhat.com 2017-08-11 16:34:48 EDT
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.
Comment 4 pulp-infra@redhat.com 2017-08-11 17:07:34 EDT
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.
Comment 5 Justin Sherrill 2017-08-16 09:55 EDT
Created attachment 1314157 [details]
el6 hotfix
Comment 6 Justin Sherrill 2017-08-16 09:56 EDT
Created attachment 1314158 [details]
el7 hotfix
Comment 7 Bernie Hoefer 2017-08-16 10:47:23 EDT
(In reply to Justin Sherrill from comment #6)
===
> Created attachment 1314158 [details]
> el7 hotfix
===

Thanks, Justin!  Quick question:  after the customer updates to the tfm-rubygem-katello packages you put in the tar file, does he need to re-run satellite-installer or restart the services?  Do these need installed on both the satellite and capsule?  Thanks!
Comment 8 Bernie Hoefer 2017-08-16 10:59:59 EDT
I just looked at a co-worker's capsule server and see those packages are not present; so I presume the hot fix ones only need installed on the satellite.

Still, please let me know if satellite-installer needs re-run or if the services just need restarted.  Thanks!
Comment 9 Justin Sherrill 2017-08-17 14:38:16 EDT
HOTFIX INSTRUCTIONS:

1) Download the hotfix tarball of your choice from this bz

2) untar the tar file

3) Install hotfix RPMs:

# yum update tfm-rubygem-katell-*

4) Restart services:

# katello-service restart
Comment 10 Justin Sherrill 2017-08-17 14:38:43 EDT
Hotfix released with instructions!
Comment 16 Brad Buckingham 2018-02-13 17:00 EST
Created attachment 1395675 [details]
RHEL7 Hotfix for Sat 6.2.14
Comment 17 Brad Buckingham 2018-02-13 17:01 EST
Created attachment 1395676 [details]
RHEL6 Hotfix for Sat 6.2.14
Comment 18 Brad Buckingham 2018-02-13 17:04:30 EST
HOTFIX INSTRUCTIONS FOR SAT 6.2.14:

1) Download the hotfix tarball of your choice from this bz
   (e.g. "RHEL7 Hotfix for Sat 6.2.14" or "RHEL6 Hotfix for Sat 6.2.14")

2) untar the tar file

3) Install hotfix RPMs:

(e.g. for RHEL7)
# yum update tfm-rubygem-katello-3.0.0.162-3_HF1466950.el7sat.noarch.rpm tfm-rubygem-katello_ostree-3.0.0.162-3_HF1466950.el7sat.noarch.rpm

4) Restart services:

# katello-service restart
Comment 21 jcallaha 2018-04-25 14:00:42 EDT
Verified in Satellite 6.2.15 Snap 1

Followed the steps outlined in the report. Used the following repo to provide SHA1 rpms.

http://koji.katello.org/releases/yum/katello-3.4/client/el5/x86_64/

Then installed the katello-host-tools package on a RHEL 5 client.



[root@qe-blade-03 ~]# yum -y install katello-host-tools
Loaded plugins: product-id, security, subscription-manager
Default_Organization_custom_sha1_test                                                                                                                                  | 1.8 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package katello-host-tools.noarch 0:3.0.2-1.el5 set to be updated
--> Processing Dependency: katello-host-tools-fact-plugin for package: katello-host-tools
--> Running transaction check
---> Package katello-host-tools-fact-plugin.noarch 0:3.0.2-1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================
 Package                                               Arch                          Version                               Repository                                                    Size
==============================================================================================================================================================================================
Installing:
 katello-host-tools                                    noarch                        3.0.2-1.el5                           Default_Organization_custom_sha1_test                         17 k
Installing for dependencies:
 katello-host-tools-fact-plugin                        noarch                        3.0.2-1.el5                           Default_Organization_custom_sha1_test                         11 k

Transaction Summary
==============================================================================================================================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 29 k
Downloading Packages:
(1/2): katello-host-tools-fact-plugin-3.0.2-1.el5.noarch.rpm                                                                                                           |  11 kB     00:00     
(2/2): katello-host-tools-3.0.2-1.el5.noarch.rpm                                                                                                                       |  17 kB     00:00     
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                          38 kB/s |  29 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : katello-host-tools-fact-plugin                                                                                                                                         1/2 
  Installing     : katello-host-tools                                                                                                                                                     2/2 
Loaded plugins: product-id

Installed:
  katello-host-tools.noarch 0:3.0.2-1.el5                                                                                                                                                     

Dependency Installed:
  katello-host-tools-fact-plugin.noarch 0:3.0.2-1.el5                                                                                                                                         

Complete!
Comment 24 errata-xmlrpc 2018-05-21 16:16:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1672

Note You need to log in before you can comment on or make changes to this bug.