Bug 14808 - old libc application not logging to syslog since 6.1
old libc application not logging to syslog since 6.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libc (Show other bugs)
6.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-28 11:35 EDT by Gary Marshall
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-28 11:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Marshall 2000-07-28 11:35:41 EDT
An application (shtml.exe from frontpage 4.0.4.3)
logs syslog messages properly under RH 6.0
but not under 6.1 or 6.2.

All 3 systems report:
    sysklogd-1.3.31-x
    libc-5.3.12-31

The 6.1 system also has:
    compat-glibc-5.2-2.0.7.1

There also seems to be other compatibility
issues with this app. But we remain clueless
without logging.
Comment 1 Bill Nottingham 2000-07-28 14:41:00 EDT
It's using the wrong socket type in libc5. Go to:

http://www.redhat.com/support/errata/rh42-errata-general.html#syslogd,

grab the libc5 binaries there, and put them in /usr/i486-linux-libc5/lib
(or whatever the directory is called; it's something close to that.)
Comment 2 Gary Marshall 2000-07-31 10:17:00 EDT
1) Links at http://www.redhat.com/support/errata/rh42-errata-
general.html#syslogd are old

2) Forcing an install of libc-5.3.12-18.5.i386.rpm has no effect
   (these install in /lib not /usr/i486-linux-libc5/lib; havent
    tried building from sources yet)

3) Installing sysklogd-1.3.31-0.5.i386.rpm gets us logging again
   (guess we will live under the shadow of syslog DOS attacks)

Note You need to log in before you can comment on or make changes to this bug.