Bug 1480811 - OpenStack Service Status is not populated for all OpenStack nodes
OpenStack Service Status is not populated for all OpenStack nodes
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity medium
: GA
: cfme-future
Assigned To: Marek Aufart
Ola Pavlenko
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-11 19:50 EDT by Jerome Marc
Modified: 2018-02-12 01:43 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-21 03:51:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack


Attachments (Terms of Use)
Inconsistent OpenStack Service Statuses across OpenStack hosts (304.08 KB, image/png)
2017-08-11 19:50 EDT, Jerome Marc
no flags Details

  None (edit)
Description Jerome Marc 2017-08-11 19:50:58 EDT
Created attachment 1312334 [details]
Inconsistent OpenStack Service Statuses across OpenStack hosts

Description of problem:
The 'OpenStack Service Status' section in the node summary for OpenStack nodes does not get populated for all nodes. 

Version-Release number of selected component (if applicable):
5.8.1.5.20170725160636_e433fc0

How reproducible:
Not sure.

Steps to Reproduce:
1. Have CF connected to OpenStack Director
2. Perform SSA on your OpenStack nodes
3. Check the 'OpenStack Service Status' section on the summary view for each node

Actual results:
'OpenStack Service Status' is inconsistent. Some node show the services, some don't.

Expected results:
All nodes should display services under 'OpenStack Service Status'.

Additional info:
See attached example.
Comment 2 Dave Johnson 2017-08-16 16:28:13 EDT
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set it to Low/Low.
Comment 3 Tzu-Mainn Chen 2017-08-21 11:32:19 EDT
Is it possible to get logs during a SSA run for a node that doesn't show openstack services?
Comment 4 Marek Aufart 2017-11-16 05:43:16 EST
As Mainn asked in August, we need see logs to identify problem (evm.log in time when SSA run on Hosts, e.g. one with correct service status and one with empty service status). We cannot progress on this BZ without that, thanks.
Comment 5 Jerome Marc 2017-11-20 16:35:22 EST
It looks like this was fixed as part of the latest CF4.5 Errata. 

After updating to 5.8.2.3.20171016155816_aaec796, I was able to get all services displayed for all OpenStack nodes following smart-state analysis.
Comment 6 Marek Aufart 2017-11-21 03:51:21 EST
Hi Jerome, thanks for information, closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.