Bug 1480833 - Heat engine throws InvalidToken error for resource-list
Summary: Heat engine throws InvalidToken error for resource-list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Rabi Mishra
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-12 03:19 UTC by PURANDHAR SAIRAM MANNIDI
Modified: 2020-09-10 11:13 UTC (History)
8 users (show)

Fixed In Version: openstack-heat-10.0.0-0.20180123134729.85a3e98.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:33:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1711047 None None None 2017-08-16 07:27:23 UTC
OpenStack gerrit 494092 'None' 'MERGED' 'Fix error for invalid auth_encryption_key' 2019-11-21 04:57:37 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:45 UTC

Description PURANDHAR SAIRAM MANNIDI 2017-08-12 03:19:01 UTC
Description of problem:

heat resource-list <stack> throws InvalidToken error and is misleading to keystone token error. In reality it's the wrong auth_encryption_key configured in /etc/heat/heat.conf.
Version-Release number of selected component (if applicable):
RH OSP 9

How reproducible:
Always

Steps to Reproduce:
1. Change the auth_encryption_key to another value
2. Restart heat-engine
3. heat resource-list fails with InvalidToken error

Actual results:
InvalidToken Error

Expected results:
Incorrect Heat Auth Encryption Key

Additional info:

Comment 8 Ronnie Rasouli 2018-06-24 09:00:58 UTC
reproduced in rhos12, verified on rhos13

Comment 10 errata-xmlrpc 2018-06-27 13:33:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.