Bug 1480927 - In the event we have two RHOSP sites using a an active/active zone, it's impossible to create buckets because the user gets created on the secondary zone and then the call is redicted to the master zone.
Summary: In the event we have two RHOSP sites using a an active/active zone, it's impo...
Keywords:
Status: CLOSED DUPLICATE of bug 1486056
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 2.*
Assignee: Matt Benjamin (redhat)
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-12 23:12 UTC by David Hill
Modified: 2021-03-11 15:35 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-22 04:09:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Hill 2017-08-12 23:12:54 UTC
Description of problem:
In the event we have two RHOSP sites using a an active/active zone, it's impossible to create buckets because the user gets created on the secondary zone and then the call is redicted to the master zone which doesn't have the newly created user on the secondary zone.   We have a workaround that is to use "openstack project list" in order to then call "radosgw-admin create user --uid ### --display-name "some_project" ... This is a ugly hack.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a multi-site ceph deployment
2. Integrate it with multi-sites keystone
3.

Actual results:
One of the zone will never be able to create buckets because it's secondary

Expected results:
Should be supported at some point without ugly hacks

Additional info:

Comment 2 Matt Benjamin (redhat) 2017-08-14 17:23:53 UTC
How does it arise that the user is created in the secondary zone?  We don't currently support this.

Matt

Comment 3 Ian Colle 2017-08-15 17:22:57 UTC
David - can you answer Matt's question above?

Comment 6 David Hill 2017-09-04 12:07:43 UTC
Hello guys,

   This was a requirement for that customer and I know this isn't supported yet but they still would like it to be supported in later Ceph releases.

Thanks,
Dave

Comment 8 Giridhar Ramaraju 2019-08-05 13:11:22 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 9 Giridhar Ramaraju 2019-08-05 13:12:21 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri


Note You need to log in before you can comment on or make changes to this bug.