Bug 1480979 - I thought it abnormal that dnf crashed.
I thought it abnormal that dnf crashed.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
: Triaged
: 1499302 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-13 06:41 EDT by Mikhail
Modified: 2017-11-10 21:54 EST (History)
7 users (show)

See Also:
Fixed In Version: dnf-2.7.4-1.fc26 dnf-2.7.4-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-25 19:11:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf full log (1.23 MB, text/plain)
2017-08-13 06:41 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2017-08-13 06:41:43 EDT
Created attachment 1312640 [details]
dnf full log

Description of problem:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1009, in run
    return self.command.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/downgrade.py", line 55, in run
    strict=self.base.conf.strict)
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 378, in downgradePkgs
    raise dnf.exceptions.Error(_('Nothing to do.'))
Comment 1 Jan Kurik 2017-08-15 03:40:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 2 Daniel Mach 2017-08-16 07:40:35 EDT
The traceback in the log is expected as user expected package downgrade and DNF wasn't able to satisfy the requirement.

The problem is probably in the error message "Nothing to do".
We need to make the message more descriptive so it's clear what's going on.
Comment 3 Jaroslav Mracek 2017-09-05 13:23:01 EDT
I created a patch that changed messages (https://github.com/rpm-software-management/dnf/pull/917). But in the log there will be still tracebacks. We can hide it, users well be probably more happy, but if any problem appears we will be unable to track it and fix it.
Comment 4 Martin Hatina 2017-10-11 08:04:01 EDT
*** Bug 1499302 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2017-10-16 05:05:26 EDT
dnf-2.7.4-1.fc26 libdnf-0.11.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9f04c2c90f
Comment 6 Fedora Update System 2017-10-16 05:06:37 EDT
dnf-2.7.4-1.fc27 libdnf-0.11.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-113a221a3d
Comment 7 Fedora Update System 2017-10-16 14:22:49 EDT
dnf-2.7.4-1.fc26, libdnf-0.11.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9f04c2c90f
Comment 8 Fedora Update System 2017-10-16 22:24:22 EDT
dnf-2.7.4-1.fc27, libdnf-0.11.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-113a221a3d
Comment 9 Fedora Update System 2017-10-25 19:11:16 EDT
dnf-2.7.4-1.fc26, libdnf-0.11.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2017-11-10 21:54:35 EST
dnf-2.7.4-1.fc27, libdnf-0.11.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.