Bug 1481005 - rpmbuild traceback by building
rpmbuild traceback by building
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Reopened
: 1481004 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-13 08:26 EDT by Dominik Kucher
Modified: 2017-08-22 16:44 EDT (History)
18 users (show)

See Also:
Fixed In Version: javapackages-tools-4.7.0-17.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-22 16:44:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Kucher 2017-08-13 08:26:04 EDT
I have updated my testserver/buildserver to fedora 26 and since i upgraded i try rebuild all my packages, but bluegriffon gives me an error.

+ STATUS=0
+ '[' 0 -ne 0 ']'
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Ausführung(%install): /bin/sh -e /var/tmp/rpm-tmp.RSczO2
+ umask 022
+ cd /home/dsoft/rpmbuild/BUILD
+ '[' /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64 '!=' / ']'
+ rm -rf /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64
++ dirname /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64
+ mkdir -p /home/dsoft/rpmbuild/BUILDROOT
+ mkdir /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64
+ cd bluegriffon-2.3.1
+ /usr/bin/install -d -m 755 /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/lib64
+ cp -a bluegriffon /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/lib64
+ /usr/bin/install -D -m 644 /home/dsoft/rpmbuild/SOURCES/bluegriffon.desktop /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/share/applications/bluegriffon.desktop
+ /usr/bin/install -D -m 644 /home/dsoft/rpmbuild/SOURCES/bluegriffon.png /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/share/pixmaps/bluegriffon.png
+ /usr/bin/install -d -m 755 /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/bin
+ ln -s /usr/lib64/bluegriffon/bluegriffon /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/bin/bluegriffon
+ ln -s /usr/lib64/bluegriffon/bluegriffon-bin /home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/bin/bluegriffon-bin
+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip /usr/bin/strip
+ /usr/lib/rpm/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+ /usr/lib/rpm/brp-python-hardlink
Dateien werden verarbeitet: bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64
[INFO osgi.prov] input: ['/home/dsoft/rpmbuild/BUILDROOT/bluegriffon-2.3.1-1.fc26.20170813.dk.x86_64/usr/lib64/bluegriffon/chrome/aria.jar']
Traceback (most recent call last):
  File "/usr/lib/rpm/osgi.prov", line 77, in <module>
    builder = TagBuilder()
  File "/usr/lib/rpm/osgi.prov", line 50, in __init__
    cache = OSGiCache(rpmconf)
  File "/usr/lib/python3.6/site-packages/javapackages/cache/osgi.py", line 52, in __init__
    self._cache = self._process_buildroot()
  File "/usr/lib/python3.6/site-packages/javapackages/cache/osgi.py", line 78, in _process_buildroot
    bundle = OSGiBundle.from_manifest(path)
  File "/usr/lib/python3.6/site-packages/javapackages/common/osgi.py", line 132, in from_manifest
    manifest = Manifest(path)
  File "/usr/lib/python3.6/site-packages/javapackages/common/manifest.py", line 48, in __init__
    self._manifest = self._read_manifest()
  File "/usr/lib/python3.6/site-packages/javapackages/common/manifest.py", line 61, in _read_manifest
    jarfile = ZipFile(self._path)
  File "/usr/lib64/python3.6/zipfile.py", line 1108, in __init__
    self._RealGetContents()
  File "/usr/lib64/python3.6/zipfile.py", line 1203, in _RealGetContents
    raise BadZipFile("Bad magic number for central directory")
zipfile.BadZipFile: Bad magic number for central directory
Terminated


[builduser@testsrv:~/rpmbuild/SPECS]$ cat bluegriffon.spec 
Name            : bluegriffon
Version         : 2.3.1
Release         : 1%{?dist}
License         : MPL
Summary         : BlueGriffon WYSIWYG-HTML Editor
Group           : Applications/Developer

URL                 : http://www.bluegriffon.org

Source0         : %{name}-%{version}.tar.gz
Source1         : bluegriffon.desktop
Source2         : bluegriffon.png


%description
BlueGriffon is a free WYSIWYG-HTML-Editor. 

%prep
%setup -c -q

%install
%{__install} -d -m 755 %{buildroot}%{_libdir}
cp -a bluegriffon %{buildroot}%{_libdir}
%{__install} -D -m 644 %{SOURCE1} %{buildroot}%{_datadir}/applications/bluegriffon.desktop
%{__install} -D -m 644 %{SOURCE2} %{buildroot}%{_datadir}/pixmaps/bluegriffon.png
%{__install} -d -m 755 %{buildroot}%{_bindir}
ln -s %{_libdir}/bluegriffon/bluegriffon %{buildroot}%{_bindir}/bluegriffon
ln -s %{_libdir}/bluegriffon/bluegriffon-bin %{buildroot}%{_bindir}/bluegriffon-bin


%post
rm -rf %{_libdir}/bluegriffon/plugins
ln -sf %{_libdir}/mozilla/plugins %{_libdir}/bluegriffon/plugins


%files 
%defattr(-, root, root)
%{_libdir}/bluegriffon/*
%{_datadir}/applications/bluegriffon.desktop
%{_datadir}/pixmaps/bluegriffon.png
%{_bindir}/bluegriffon
%{_bindir}/bluegriffon-bin
Comment 1 Dominik Kucher 2017-08-13 08:29:02 EDT
*** Bug 1481004 has been marked as a duplicate of this bug. ***
Comment 2 Michael Simacek 2017-08-14 03:25:50 EDT
Can you please provide an SRPM?
Comment 3 Dominik Kucher 2017-08-14 15:29:52 EDT
thats my srpm!

http://dk-technik.org/srpm/bluegriffon-2.3.1-1.fc25.20170814.dk.src.rpm
Comment 4 Dominik Kucher 2017-08-15 01:22:09 EDT
now the download works! 

http://dk-technik.org/srpm/bluegriffon-2.3.1-1.fc25.20170814.dk.src.rpm
Comment 5 Mikolaj Izdebski 2017-08-16 09:23:18 EDT
Proposed fix submitted at https://github.com/fedora-java/javapackages/pull/46
Comment 6 Fedora Update System 2017-08-17 07:03:48 EDT
javapackages-tools-4.7.0-17.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5e996820b5
Comment 7 Fedora Update System 2017-08-19 14:54:59 EDT
javapackages-tools-4.7.0-17.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5e996820b5
Comment 8 Dominik Kucher 2017-08-19 18:30:44 EDT
it works with the new javapackages-tools, i have download it few days agon from koji and test it that's why i have close the bug
Comment 9 Mikolaj Izdebski 2017-08-22 05:16:34 EDT
(In reply to Dominik Kucher from comment #8)
> it works with the new javapackages-tools, i have download it few days agon
> from koji and test it that's why i have close the bug

Thank you for confirming this. But the fix is not yet delivered to end users, so the bug should stay open for now, until erratum is pushed to stable updates repository.
Comment 10 Fedora Update System 2017-08-22 16:44:13 EDT
javapackages-tools-4.7.0-17.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.