Bug 1481008 - http-parser removed from EPEL - Dependency of Node.js
Summary: http-parser removed from EPEL - Dependency of Node.js
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: http-parser (Show other bugs)
(Show other bugs)
Version: epel7
Hardware: x86_64 Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1485803 (view as bug list)
Depends On: 1477662
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-13 12:51 UTC by Dan Aharon
Modified: 2018-04-11 07:34 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 12:52:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1457763 None None None Never
Red Hat Bugzilla 1481470 None None None Never

Description Dan Aharon 2017-08-13 12:51:02 UTC
Description of problem:
When trying to install Node.js I receive the following error:

Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: libhttp_parser.so.2()(64bit)
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: http-parser >= 2.7.0

Looking at the EPEL repository and mirrors, it appears that the package has been removed.


Steps to Reproduce:
1. # yum install nodejs


Actual results:
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: libhttp_parser.so.2()(64bit)
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: http-parser >= 2.7.0


Expected results:
Successful installation of the nodejs package.

Comment 1 Dan Aharon 2017-08-13 13:19:06 UTC
Looks like it's related to

Comment 2 Anssi Johansson 2017-08-13 15:08:02 UTC
The package was removed from EPEL because http-parser is now included in RHEL 7.4, and EPEL does not ship packages that are also in RHEL.

https://access.redhat.com/errata/RHBA-2017:1974 -- "New http-parser packages are now available for Red Hat Enterprise Linux 7"

Comment 3 Dan Aharon 2017-08-14 07:22:20 UTC
Meanwhile, the http-parser package can be downloaded here:
https://kojipkgs.fedoraproject.org/packages/http-parser/2.7.1/3.el7/x86_64/

Comment 4 Stephen Gallagher 2017-08-14 12:52:54 UTC
This is because of https://bugzilla.redhat.com/show_bug.cgi?id=1477662

The http-parser package is now available in RHEl 7.4 (and will be available from the CentOS update repositories soon if not already).

Comment 5 Brian J. Murrell 2017-08-15 11:21:41 UTC
But why is a change like this being made knowing it will break CentOS (and other EL derivative) users for a period of time?

And it will continue to break for any user who is unable to jump up to EL 7.4 immediately.  That's not an insignificant number of people.  Corporate polices can forbid minor upgrades until compatibility testing, audit, approval, etc. are performed.

Surely there is no issue with having a package in both EPEL and RHEL for at least a reasonable amount of time while other EL-based distros (including your own CentOS) catch up and users can perform their due diligence before doing upgrades.

Comment 6 Stephen Gallagher 2017-08-15 11:56:43 UTC
(In reply to Brian J. Murrell from comment #5)
> But why is a change like this being made knowing it will break CentOS (and
> other EL derivative) users for a period of time?
> 
> And it will continue to break for any user who is unable to jump up to EL
> 7.4 immediately.  That's not an insignificant number of people.  Corporate
> polices can forbid minor upgrades until compatibility testing, audit,
> approval, etc. are performed.
> 
> Surely there is no issue with having a package in both EPEL and RHEL for at
> least a reasonable amount of time while other EL-based distros (including
> your own CentOS) catch up and users can perform their due diligence before
> doing upgrades.

Please see my detailed reply on https://bugzilla.redhat.com/show_bug.cgi?id=1481470

Comment 7 Igor Gnatenko 2017-08-28 06:52:26 UTC
*** Bug 1485803 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.