Bug 1481032 - dnf system-upgrade marks all installed packages repo as @@commandline
dnf system-upgrade marks all installed packages repo as @@commandline
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-13 13:55 EDT by John Griffiths
Modified: 2017-08-15 03:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 03:44:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2017-08-13 13:55:46 EDT
Description of problem:
Upgraded from Fedora 24 to Fedors 26 using DNF system upgrade. The commands used were as in the instructions.
dnf system-upgrade download --refresh -releaseserver=26
dnf system-upgrade reboot

Version-Release number of selected component (if applicable):
2.6.3

How reproducible:
I upgraded two systems and it happened on both.

Steps to Reproduce:
1. Use dnf to do a system upgrade.
2. run dnf list installed

Actual results:
All the packages upgraded are marked as being installed from the  commandline which is technically true, but not quite what I expect.

Expected results:
I expect the repo of the packages to be the repo from which it was downloaded.

Additional info:
When dnf upgrade is run and packages are updated, the repo information is updated.

Apparently, running 
dnf repository-packages @@commandline remove-or-reinstall
will reinstall all the packages so then they will have the correct repo name. Seems excessive since all the packages have to be downloaded again.
Comment 1 Jaroslav Mracek 2017-08-15 03:44:37 EDT
The problem was recently fixed in pythonX-dnf-plugin-system-upgrade-2.0.2-1, that is available for Fedora 26.

Note You need to log in before you can comment on or make changes to this bug.