Fedora Account System
Red Hat Associate
Red Hat Customer
This is happening after the scanning job was aborted most commonly due to timeout. It is not effecting the result but this error should be avoided. I will create a PR to clean the dangling queue messages like we are doing when a scanning job is being canceled by the user.
How to reproduce: 1. Change the timeout settings for container scanning jobs to "1.second" in the config/settings.yml file under "container_scanning.scanning_job_timeout" 2. Run SSA on a container image. it will fail due to timeout 3. In the log search for the string "pod_wait is not permitted at state finished" from the last scan. It will be followed by a stacktrace. Fixing PR: https://github.com/ManageIQ/manageiq-providers-kubernetes/pull/99
:+1: https://bugzilla.redhat.com/show_bug.cgi?id=1481230#c5
Created attachment 1351576 [details] evm.log
Hi Erez Following your instructions after getting timeout error , i didn't find string "pod_wait is not permitted at state finished" on attach evm.log! On which log file should i search for the above error?
Verified on 5.8.2.3.20171016155816_aaec796 get tasks error message on timeout. also get on evm.log "pod_wait is not permitted at state finished" also verified on 5.9.0.8 --> also get tasks error message on timeout as expected on this version.