Bug 14815 - I have 384 Mb of RAM, Linux say me i have only 64
I have 384 Mb of RAM, Linux say me i have only 64
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-28 14:19 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 08:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-07-28 14:19:30 EDT
I've installed a server with these components:

AMD Athlon 800Mhz
Motherboard Gigabyte 7AX (2X AGP and 100Mhz DIMM)
384 Mb DIMM 133Mhz
Video Card Matrox G200 8Mb
Controller Adaptec 39160 Ultra2Wide SCSI
Hard Disk Seagate Cheetah 18.4 Gb 10.000 rpm
Hard Disk Quantum 10.1 Gb EIDE
2 CD-ROM & 1 DVD SCSI
1 CD-ROM EIDE
Audio Card Forte' Media (the chip)

Problem: At the Boot in Every possible configuration of the DIMM Linux
can see ONLY 64 Mb of RAM (The Mainboard Display correctly the size, but if
i mount 128, 256 or 384 Mb the Linux Say me that i have only 64 Mb.

You have an idea regarding this?

Thank you and sorry but no solution (upgrade bios or other) do not resolve 
my problem.
Comment 1 keith.moore 2000-08-17 08:27:49 EDT
Here is a Workaround that should work:

append="mem=384MB"

assuming linux is your image name, boot and at the LILO: prompt type:

linux mem=384MB

If this works, then update lilo.conf.  Do NOT get this parameter wrong, Linux
will try to use memory that doesn't exist.

Add the line

append="mem=384MB" to your kernel entry in /etc/lilo.conf

-- Keith Moore
Comment 2 Alan Cox 2000-08-22 12:50:52 EDT
Its dependant on the BIOS. The 2.4 series kernels will use the same bios
interface windows does because it seems thats the only way a bios vendor
implements things properly

Note You need to log in before you can comment on or make changes to this bug.