Bug 1482107 - xrdp Xorg session doesn't start after RHEL 7.3 to 7.4 update due to undefined symbol error
Summary: xrdp Xorg session doesn't start after RHEL 7.3 to 7.4 update due to undefined...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xorgxrdp
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Roskin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1499092 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-16 13:20 UTC by Dominik Mierzejewski
Modified: 2017-10-09 01:48 UTC (History)
5 users (show)

Fixed In Version: xorgxrdp-0.2.4-3.fc25 xorgxrdp-0.2.4-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-06 18:50:06 UTC


Attachments (Terms of Use)

Description Dominik Mierzejewski 2017-08-16 13:20:54 UTC
Description of problem:
xrdp Xorg session fails to start after RHEL 7.3 to 7.4 update.

Version-Release number of selected component (if applicable):
xorgxrdp-0.2.3-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install and configure xrdp with Xorg backend on RHEL 7.3.
2. Update to RHEL 7.4.
3. Try logging in over RDP.

Actual results:
Xorg fails to start. The following errors can be seen in $HOME/.xorgxrdp.17.log:
[...]
[626279.399] (II) LoadModule: "xorgxrdp"
[626279.399] (II) Loading /usr/lib64/xorg/modules/libxorgxrdp.so
[626279.399] (II) Module XORGXRDP: vendor="X.Org Foundation"
[626279.399]    compiled for 1.17.2, module version = 1.0.0
[626279.399]    ABI class: X.Org Video Driver, version 19.0
[626279.399] (EE) xorgxrdp: module ABI major version (19) doesn't match the server's version (23)
[626279.399] (II) UnloadModule: "xorgxrdp"
[626279.399] (II) Unloading xorgxrdp
[626279.400] (EE) Failed to load module "xorgxrdp" (module requirement mismatch, 0)
[626279.400] (II) LoadModule: "fb"
[626279.400] (II) Loading /usr/lib64/xorg/modules/libfb.so
[626279.400] (II) Module fb: vendor="X.Org Foundation"
[626279.400]    compiled for 1.19.3, module version = 1.0.0
[626279.400]    ABI class: X.Org ANSI C Emulation, version 0.4
[626279.400] (II) LoadModule: "xrdpdev"
[626279.400] (II) Loading /usr/lib64/xorg/modules/drivers/xrdpdev_drv.so
[626279.400] (EE) Failed to load /usr/lib64/xorg/modules/drivers/xrdpdev_drv.so: /usr/lib64/xorg/modules/drivers/xrdpdev_drv.so: undefined symbol: rdpRRModeDestroy
[626279.400] (II) UnloadModule: "xrdpdev"
[626279.400] (II) Unloading xrdpdev
[626279.400] (EE) Failed to load module "xrdpdev" (loader failed, 7)
[626279.400] (II) LoadModule: "xrdpmouse"
[626279.400] (II) Loading /usr/lib64/xorg/modules/input/xrdpmouse_drv.so
[626279.400] (II) Module XRDPMOUSE: vendor="X.Org Foundation"
[626279.400]    compiled for 1.17.2, module version = 1.0.0
[626279.400]    Module class: X.Org XInput Driver
[626279.400]    ABI class: X.Org XInput driver, version 21.0
[626279.400] (EE) xrdpmouse: module ABI major version (21) doesn't match the server's version (24)
[626279.400] (II) UnloadModule: "xrdpmouse"
[626279.400] (II) Unloading xrdpmouse
[626279.400] (EE) Failed to load module "xrdpmouse" (module requirement mismatch, 0)
[626279.400] (II) LoadModule: "xrdpkeyb"
[626279.400] (II) Loading /usr/lib64/xorg/modules/input/xrdpkeyb_drv.so
[626279.400] (II) Module XRDPKEYB: vendor="X.Org Foundation"
[626279.400]    compiled for 1.17.2, module version = 1.0.0
[626279.400]    Module class: X.Org XInput Driver
[626279.400]    ABI class: X.Org XInput driver, version 21.0
[626279.400] (EE) xrdpkeyb: module ABI major version (21) doesn't match the server's version (24)
[626279.400] (II) UnloadModule: "xrdpkeyb"
[626279.400] (II) Unloading xrdpkeyb
[626279.400] (EE) Failed to load module "xrdpkeyb" (module requirement mismatch, 0)
[626279.400] (EE) No drivers available.
[626279.400] (EE)
Fatal server error:
[626279.400] (EE) no screens found(EE)
[626279.400] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[626279.400] (EE) Please also check the log file at ".xorgxrdp.17.log" for additional information.
[626279.400] (EE)
[626279.400] (EE) Server terminated with error (1). Closing log file.

Expected results:
Successful Xorg start.

Additional info:
Downgrading the Xorg server back to 1.17.2-22.el7 makes it work again, so I guess xorgxrdp needs to be rebuilt against the new Xorg ABI.

Comment 1 Fedora Update System 2017-09-20 01:26:26 UTC
xorgxrdp-0.2.4-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-35d2f7a90a

Comment 2 Fedora Update System 2017-09-20 01:26:40 UTC
xorgxrdp-0.2.4-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-69df2856c2

Comment 3 Fedora Update System 2017-09-20 01:26:49 UTC
xorgxrdp-0.2.4-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec0a55c31d

Comment 4 Fedora Update System 2017-09-20 01:26:58 UTC
xorgxrdp-0.2.4-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f834c2cd8f

Comment 5 Fedora Update System 2017-09-20 15:21:27 UTC
xorgxrdp-0.2.4-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f834c2cd8f

Comment 6 Fedora Update System 2017-09-20 20:19:16 UTC
xorgxrdp-0.2.4-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-69df2856c2

Comment 7 Fedora Update System 2017-09-20 20:48:57 UTC
xorgxrdp-0.2.4-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec0a55c31d

Comment 8 Fedora Update System 2017-09-20 23:50:38 UTC
xorgxrdp-0.2.4-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-35d2f7a90a

Comment 9 elinde 2017-09-21 02:48:49 UTC
Suggestion: the dependency on xorg-x11-server-Xorg should require the *same* version that xorgxrdp was built with.

So xorgxrdp-0.2.3-1.el7.x86_64 should have required xorg-x11-server-common-1.17.2.

Note especially the 2nd and 5th lines below:

[626279.400] (II) Module XRDPMOUSE: vendor="X.Org Foundation"
[626279.400]    compiled for 1.17.2, module version = 1.0.0
[626279.400]    Module class: X.Org XInput Driver
[626279.400]    ABI class: X.Org XInput driver, version 21.0
[626279.400] (EE) xrdpmouse: module ABI major version (21) doesn't match the server's version (24)

Also see:

https://github.com/neutrinolabs/xrdp/issues/786#issuecomment-326179740

Comment 10 Fedora Update System 2017-09-22 23:10:22 UTC
xorgxrdp-0.2.4-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-69df2856c2

Comment 11 Fedora Update System 2017-09-22 23:11:31 UTC
xorgxrdp-0.2.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f834c2cd8f

Comment 12 Fedora Update System 2017-09-22 23:12:31 UTC
xorgxrdp-0.2.4-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec0a55c31d

Comment 13 Fedora Update System 2017-09-22 23:14:28 UTC
xorgxrdp-0.2.4-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-35d2f7a90a

Comment 14 Fedora Update System 2017-09-23 18:26:52 UTC
xorgxrdp-0.2.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f834c2cd8f

Comment 15 Fedora Update System 2017-09-23 20:48:55 UTC
xorgxrdp-0.2.4-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-69df2856c2

Comment 16 Fedora Update System 2017-09-24 05:49:25 UTC
xorgxrdp-0.2.4-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ec0a55c31d

Comment 17 Fedora Update System 2017-09-24 05:51:34 UTC
xorgxrdp-0.2.4-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-35d2f7a90a

Comment 18 Fedora Update System 2017-09-30 06:43:17 UTC
xorgxrdp-0.2.4-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Bojan Smojver 2017-10-06 02:51:58 UTC
*** Bug 1499092 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2017-10-06 15:20:09 UTC
xorgxrdp-0.2.4-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Dominik Mierzejewski 2017-10-06 16:03:05 UTC
Surely it doesn't make sense to say an EPEL-only bug is fixed by a Fedora package. Also, moving back to ON_QA status because the EPEL package is not stable yet.

Comment 22 Fedora Update System 2017-10-06 18:50:06 UTC
xorgxrdp-0.2.4-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2017-10-09 01:48:54 UTC
xorgxrdp-0.2.4-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.