Bug 1482460 - [AWS][EC2]The system disk partition type displays as "Microsoft basic data" in RHEL guests on EC2
Summary: [AWS][EC2]The system disk partition type displays as "Microsoft basic data" i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ec2-images
Version: 7.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jon Disnard
QA Contact: Lin Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-17 10:39 UTC by Lin Liu
Modified: 2019-08-06 11:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 11:41:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2351 None None None 2019-08-06 11:42:12 UTC

Description Lin Liu 2017-08-17 10:39:51 UTC
Description of problem:

The system disk partition type displays as "Microsoft basic data" in RHEL guests on EC2.

[root@ip-172-31-8-133 ~]# fdisk -l
...
#         Start          End    Size  Type            Name
 1         2048         4095      1M  BIOS boot parti
 2         4096     41943006     20G  Microsoft basic


Version-Release number of selected component (if applicable):
RHEL7.4

How reproducible:
100%

Steps to Reproduce:

1. Start a RHEL7.4 instance on EC2.
2. Connect the instance and check the partition type of the system disk with "sudo fdisk -l" command.

Actual results:
The Partition type is "Microsoft basic data" as default.

Expected results:
The Partition type should be "Linux filesystem".

Additional info:
1. The default partition type is "Microsoft basic data" if using "parted" command to manipulate disk partitions.
   We can see from the ks file "original-ks.cfg" in the instance that we use parted command during building the image, so please change the partition type after manipulating disk partitions or using fdisk to make the partitions.
2. I checked Amazon Linux, the partition type is "Linux filesystem".

Comment 10 errata-xmlrpc 2019-08-06 11:41:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2351


Note You need to log in before you can comment on or make changes to this bug.