Bug 1482512 - Failed to install liveimg on FCoE storage
Summary: Failed to install liveimg on FCoE storage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: pre-dev-freeze
: 7.5
Assignee: Blivet Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng-43-el76-platform
TreeView+ depends on / blocked
 
Reported: 2017-08-17 12:51 UTC by cshao
Modified: 2018-07-31 14:37 UTC (History)
16 users (show)

Fixed In Version: python-blivet-0.61.15.67-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 18:23:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
all log (291.55 KB, application/x-gzip)
2017-08-17 12:51 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3548581 None None None 2018-07-31 14:37:31 UTC
Red Hat Product Errata RHBA-2018:0982 None None None 2018-04-10 18:24:04 UTC

Description cshao 2017-08-17 12:51:13 UTC
Created attachment 1314706 [details]
all log

Description of problem:
Failed to install RHVH on FCoE storage.

19:57:07,358 INFO anaconda: Running pre-installation scripts
19:57:07,585 INFO anaconda: Running Thread: AnaLiveProgressThread (139919595026176)
19:57:58,176 INFO anaconda: Thread Done: AnaLiveProgressThread (139919595026176)
19:57:59,329 DEBUG anaconda: running handleException
19:57:59,330 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)

  File "/usr/lib64/python2.7/threading.py", line 765, in run
    self.__target(*self.__args, **self.__kwargs)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 274, in doInstall
    storage.write()

  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1622, in write
    self.fcoe.write(_sysroot)

  File "/usr/lib/python2.7/site-packages/blivet/fcoe.py", line 202, in write
    shutil.copytree("/etc/fcoe", root + "/etc/fcoe")

  File "/usr/lib64/python2.7/shutil.py", line 177, in copytree
    os.makedirs(dst)

  File "/usr/lib64/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)

OSError: [Errno 17] File exists: '/mnt/sysimage/etc/fcoe'

19:57:59,331 DEBUG anaconda: Gtk running, queuing exception handler to the main loop
19:57:59,331 INFO anaconda: Thread Done: AnaInstallThread (139919604471552)
19:58:05,728 INFO anaconda: Running kickstart %%onerror script(s)
19:58:05,728 INFO anaconda: All kickstart %%onerror script(s) have been run
19:58:05,729 INFO anaconda: Running kickstart %%traceback script(s)
19:58:05,729 INFO anaconda: All kickstart %%traceback script(s) have been run


Version-Release number of selected component (if applicable):
RHVH-4.1-20170817.0-RHVH-x86_64-dvd1.iso 
fcoe-utils-1.0.32-1.el7.x86_64
imgbased-0.9.47-0.1.el7ev.noarch

Machine: 
dell-per730-35
10GB FCoE / SR-IOV, Intel X520 Adapter -- connect to FCoE storage

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH 4.1.5 on FCoE storage.
2. Specialized & Network disks 
  -> Add a disk 
     -> Add FCoE SAN 
        -> NIC(p5p1/p5p2) 
           -> choose both "Use DCB" and "use auto Vlan"
3. Choose the FCoE boot lun to install RHVH.
4. Choose auto/manual partitioning on Anaconda GUI, and finish other mandatory steps. 
5. Focus on the installation process.

Actual results:
Failed to install RHVH on FCoE storage.


Expected results:
Install RHVH on FCoE storage can successful.

Additional info:
The same issue occurs on RHVH 4.1.4 ASYNC(redhat-virtualization-host-4.1-20170808.0)

Comment 3 Radek Vykydal 2018-02-05 11:35:14 UTC
Seems to be a consequence of
https://github.com/storaged-project/blivet/commit/2ed433f1d906accf4f77660ce0ff036797f43662

For RHEV image install there is probably already /etc/fcoe dir existing on the image. I think we should be able handle this case, I'll look at it.

Comment 4 Radek Vykydal 2018-02-05 11:41:07 UTC
Could you please provide a link to HVH-4.1-20170817.0-RHVH-x86_64-dvd1.iso or similar so I can debug the issue? Thank you.

Comment 6 Radek Vykydal 2018-02-06 09:18:04 UTC
PR with fix:

https://github.com/storaged-project/blivet/pull/656

You can check if the fix works for you using this updates image with the patch:
https://rvykydal.fedorapeople.org/updates.fcoe-rhev.img

It can be applied to an installation by adding installer boot option "updates", eg:

updates=https://rvykydal.fedorapeople.org/updates.fcoe-rhev.img

or by using kickstart "updates" command:

updates https://rvykydal.fedorapeople.org/updates.fcoe-rhev.img

Comment 7 Samantha N. Bueno 2018-02-06 10:38:46 UTC
Switching this over to python-blivet, since that is the component which the fix is for.

Also setting blocker? since this is a significant issue for our layered products (RHVH). The fix should be quite safe.

Comment 9 Jan Stodola 2018-02-06 14:37:45 UTC
FYI, updates.img from comment 6 fixes the problem for me.

Comment 14 Jan Stodola 2018-02-23 08:33:47 UTC
Thank you for confirming this is fixed for you.

Moving to VERIFIED based on comment 13.

Comment 18 errata-xmlrpc 2018-04-10 18:23:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0982


Note You need to log in before you can comment on or make changes to this bug.