Bug 14830 - Crypt::DES is corrupted on apache httpd server..
Summary: Crypt::DES is corrupted on apache httpd server..
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Other (Show other bugs)
(Show other bugs)
Version: current
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Paul Lindner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-29 01:13 UTC by Paul Lindner
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-29 17:41:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Lindner 2000-07-29 01:13:01 UTC
When Crypt::DES is dynamically loaded on the webdev mod_perl server it
fails to encrypt properly.  

If it's loaded statically in startup.pl then all seems fine. (as tested on
my local web server..)

Smooge, could you:

  1) Add the perl-Crypt-DES-1.01-1.rpm to the app servers
  2) Update the app conf file startup.pl  to version 1.4 (I've committed it
to CVS)
  3) Restart the app servers..

Thanks.

Comment 1 Stephen John Smoogen 2000-07-29 17:41:49 UTC
I am going to get the RPM. Do you want this on webdev (first line of ticket) or
on the app servers?

Sorry.. a bit confused.

Comment 2 Paul Lindner 2000-08-04 01:14:03 UTC
This problem is actually caused by loading the mod_ssl module into the apache
server.  Seems like a namespace collision on the DES functions....

Anyway, this should now be resolved on all boxes..

thanks.



Note You need to log in before you can comment on or make changes to this bug.