Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1483051 - Rebase ModemManager to new upstream version [NEEDINFO]
Rebase ModemManager to new upstream version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ModemManager (Show other bugs)
7.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Lubomir Rintel
Desktop QE
Ioanna Gkioka
: Rebase
Depends On:
Blocks: 1470965 1491343
  Show dependency treegraph
 
Reported: 2017-08-18 12:34 EDT by Thomas Haller
Modified: 2018-04-10 06:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: ModemManager-1.6.8-1.el7, libqmi-1.18.0-1.el7, libmbim-1.14.2-1.el7, usb_modeswitch-2.5.1-1.el7, usb_modeswitch-data-20170806-1.el7
Doc Type: Release Note
Doc Text:
_ModemManager_ rebased to version 1.6.8 The _ModemManager_ package has been upgraded to upstream version 1.6.8 to support newer modem hardware. This provides a number enhancements over the previous version. Notably, the version of the `libqmi` library has been upgraded to 1.18.0 and the `libmbim` library to 1.14.2. In addition, the `usb_modeswitch` tool has been upgraded to 2.5.1 and the _usb-modeswitch-data_ package to 20170806.
Story Points: ---
Clone Of:
: 1491343 (view as bug list)
Environment:
Last Closed: 2018-04-10 06:10:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
igkioka: needinfo? (lrintel)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0699 None None None 2018-04-10 06:10 EDT

  None (edit)
Description Thomas Haller 2017-08-18 12:34:23 EDT
For RHEL-7.5 we'd like to improve modem support.


In rhel-7.4 we have MM-1.6.0.

We could either rebase to
  - 1.6.8 (which is latest upstream release)
  - 1.6.10 (or newer), which would be yet-to-be-release 1.8
  - 1.10.0 (or newer), which is current master, not yet released.

I think we should aim for 1.6.10.


Rebasing to not-yet-released 1.10.0 would also require a rebase of libqmi.
Comment 2 Lubomir Rintel 2017-08-29 08:50:07 EDT
Updated ModemManager and the associated libraries:

ModemManager-1.6.8-1.el7
libqmi-1.18.0-1.el7
libmbim-1.14.2-1.el7
usb_modeswitch-2.5.1-1.el7
usb_modeswitch-data-20170806-1.el7
Comment 8 errata-xmlrpc 2018-04-10 06:10:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0699

Note You need to log in before you can comment on or make changes to this bug.