Bug 1483253 - dnf download command fails with "No such command: download. Please use /usr/bin/dnf --help"
Summary: dnf download command fails with "No such command: download. Please use /usr/b...
Keywords:
Status: CLOSED DUPLICATE of bug 1483342
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2017-08-19 16:59 UTC by Richard W.M. Jones
Modified: 2017-08-23 11:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-23 11:08:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2017-08-19 16:59:19 UTC
Description of problem:

No such command: download. Please use /usr/bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(download)'"

Did this command get moved to another plugin?

Version-Release number of selected component (if applicable):

dnf 2.6.3-2.fc28
dnf-plugins-core 2.1.3-2.fc27

How reproducible:

?

Steps to Reproduce:
1. Try to run ‘dnf download’ command.

Failed build:

https://koji.fedoraproject.org/koji/taskinfo?taskID=21329960

Comment 1 Richard W.M. Jones 2017-08-19 17:01:24 UTC
Also fails in Fedora 27:
https://koji.fedoraproject.org/koji/taskinfo?taskID=21330125

Please add a regression test so this subcommand doesn't break so much.

Comment 2 Jaroslav Mracek 2017-08-21 08:57:46 UTC
I am really sorry, but the release of dnf-2.6.3-2 was not under control of dnf team and additionally we disagreed with that change. The problem is that the release is using platform-python and plugins not.

Comment 3 Igor Gnatenko 2017-08-23 11:08:00 UTC

*** This bug has been marked as a duplicate of bug 1483342 ***


Note You need to log in before you can comment on or make changes to this bug.