Bug 1483272 - [regression] no output on HDMI until Xorg starts after upgrade to kernel 4.12.5
Summary: [regression] no output on HDMI until Xorg starts after upgrade to kernel 4.12.5
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-19 23:55 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2018-03-06 10:20 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-06 10:20:52 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 102312 None None None 2017-08-19 23:55 UTC

Description Dominik 'Rathann' Mierzejewski 2017-08-19 23:55:42 UTC
Description of problem:
After upgrading from kernel-4.11.11-300.fc26.x86_64 to 4.12.5-300.fc26.x86_64, I no longer get any video output (in particular: the LUKS password prompt) on the external monitor connected to the HDMI port. It's only displayed on the internal LCD. The external monitor shows the expected video output only after Xorg starts.

Version-Release number of selected component (if applicable):
4.12.5-300.fc26.x86_64

How reproducible:
Always

Steps to Reproduce:
1. On a Sony Vaio Pro 13 (Haswell), connect an external monitor to HDMI
2. Install Fedora 26 with encrypted rootfs
3. Boot kernel 4.12.5-300.fc26.x86_64

Actual results:
Kernel/systemd messages and LUKS password prompt are displayed only on internal LCD.

Expected results:
All messages, including LUKS password prompt should appear on the external monitor connected to HDMI port as well.

Additional info:
This is a regression from 4.11.11-300.fc26.x86_64.

Comment 1 Dominik 'Rathann' Mierzejewski 2017-09-04 14:43:20 UTC
Per upstream suggestion, I tried building the kernel (4.13.0-rc7) from drm-tip (https://cgit.freedesktop.org/drm-tip) and it doesn't seem to suffer from this issue. So, assuming drm-tip is merged into 4.13, this will probably be fixed by updating to 4.13 in F26.

Comment 2 Dominik 'Rathann' Mierzejewski 2017-10-06 11:55:05 UTC
I updated to 4.13.4-200.fc26.x86_64 and the issue persists, so I can only conclude that this is due to some Fedora-specific patch.

Comment 3 Justin M. Forbes 2017-10-09 16:03:21 UTC
At the rc-7 phase, DRM tip would be merged into the .14 merge window, not into .13. Mind trying a rawhide kernel and see if that fixes the issue for you?

Comment 4 Dominik 'Rathann' Mierzejewski 2017-10-11 12:54:11 UTC
I'll have to verify at home with another monitor, but the problem seems to be gone in 4.14.0-0.rc4.git0.1.fc28.x86_64 . I haven't tried any earlier versions.

Comment 5 Dominik 'Rathann' Mierzejewski 2017-12-05 08:40:10 UTC
I upgraded to F27 in the meantime and installed 4.14.3-300.fc27.x86_64 kernel from koji. Issue is gone here, too.

Comment 6 m3more 2017-12-29 20:14:42 UTC
4.14.8-300.fc27.x86_64
Bug still here

laptop lcd panel blank after boot start.
hp 8440p, second monitor connected to vga port

Comment 7 Dominik 'Rathann' Mierzejewski 2017-12-29 22:14:26 UTC
(In reply to m3more from comment #6)
> 4.14.8-300.fc27.x86_64
> Bug still here
> 
> laptop lcd panel blank after boot start.
> hp 8440p, second monitor connected to vga port

Yours looks like a reverse of mine and I do get output on second monitor after Xorg startup, so it's a different bug. Please don't add confusion here.

Comment 8 Laura Abbott 2018-02-28 03:38:45 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.

Comment 9 Dominik 'Rathann' Mierzejewski 2018-03-06 10:20:52 UTC
As mentioned before, this is fixed in 4.14 and later, so closing.


Note You need to log in before you can comment on or make changes to this bug.