Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1483387

Summary: [3.6] Installation by openshift-ansible failed at task openshift_node_dnsmasq : Install dnsmasq configuration
Product: OpenShift Container Platform Reporter: Weihua Meng <wmeng>
Component: InstallerAssignee: Scott Dodson <sdodson>
Status: CLOSED ERRATA QA Contact: Johnny Liu <jialiu>
Severity: high Docs Contact:
Priority: high    
Version: 3.6.0CC: aos-bugs, jokerman, mmccomas
Target Milestone: ---   
Target Release: 3.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
When users had set openshift_dns_ip it was not properly configuring the node-config.yaml file to use this value which resulted in a broken dns configuration. This error has been corrected.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-05 17:42:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Weihua Meng 2017-08-21 02:14:53 UTC
Description of problem:
Installation by openshift-ansible failed at task 
openshift_node_dnsmasq : Install dnsmasq configuration


Version-Release number of the following components:
openshift-ansible-3.6.173.0.5-5.git.0.0538d97.el7.noarch.rpm
ansible-2.3.1.0

How reproducible:
Always
Steps to Reproduce:
1. install openshift by openshift-ansible

Actual results:
TASK [openshift_node_dnsmasq : Install dnsmasq configuration] ******************
Monday 21 August 2017  01:45:42 +0000 (0:00:00.886)       0:06:30.261 ********* 
fatal: [host-8-241-75.host.centralci.eng.rdu2.redhat.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

AnsibleUndefinedVariable: 'dict object' has no attribute 'dns_ip'

----
Failure summary:

  1. Host:     host-8-241-75.host.centralci.eng.rdu2.redhat.com
     Play:     Configure containerized nodes
     Task:     openshift_node_dnsmasq : Install dnsmasq configuration
     Message:  AnsibleUndefinedVariable: 'dict object' has no attribute 'dns_ip'

Expected results:
Installation succeed.

Additional info:

Comment 3 Weihua Meng 2017-08-23 01:26:56 UTC
Verified with openshift-ansible-3.6.173.0.7-2.git.0.340aa2c.el7.noarch.rpm
Fixed.
Installation succeed.

Comment 5 errata-xmlrpc 2017-09-05 17:42:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639