Bug 1483433 - [UI] - Can't see the subnets of external network
Summary: [UI] - Can't see the subnets of external network
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-21 06:15 UTC by Michael Burman
Modified: 2017-12-20 10:54 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.2.0-0.0.master.20170901193740.git7900511.el7.centos.noarch.rpm
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:54:46 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
ui log (36.56 KB, application/x-gzip)
2017-08-21 06:15 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 81236 0 master MERGED webadmin: display external network 2017-08-30 19:29:38 UTC

Description Michael Burman 2017-08-21 06:15:26 UTC
Created attachment 1316117 [details]
ui log

Description of problem:
[UI] - Can't see the subnets of external network.

There is a UI exception when going to Subnets sub tab under Networks - 

2017-08-21 09:02:32,847+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-7) [] Permutation name: 4D2F00258F2C0228C8F11BB98BBD77D8
2017-08-21 09:02:32,847+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-7) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) : Cannot read property 'nh' of null
        at java.lang.String.join(String.java:123) [rt.jar:1.8.0_131]
        at org.ovirt.engine.ui.webadmin.section.main.view.tab.network.SubTabNetworkExternalSubnetView$5.getValue(SubTabNetworkExternalSubnetView.java:87)
        at com.google.gwt.user.cellview.client.Column.render(Column.java:164) [gwt-servlet.jar:]

The subnet it self is not displayed. 

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170820180837.git59243e9.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Import external network from a network provider to rhv 4.2
2. Go to Networks > Network > Subnets 

Actual results:
Can't see the subnet, a UI exception appears

Expected results:
Should work as expected

Comment 1 Red Hat Bugzilla Rules Engine 2017-08-22 05:38:23 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Michael Burman 2017-09-03 05:51:29 UTC
Verified on - 4.2.0-0.0.master.20170901193740.git7900511.el7.centos

Comment 3 Sandro Bonazzola 2017-12-20 10:54:46 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.