Bug 1483521 - Trim whitespaces in all the user provided text in the cockpit UI
Summary: Trim whitespaces in all the user provided text in the cockpit UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.10.7-0.0.23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.1.6
: ---
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-21 10:45 UTC by SATHEESARAN
Modified: 2017-09-19 10:02 UTC (History)
5 users (show)

Fixed In Version: cockpit-ovirt-0.10.8-2.0.ovirt41.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1455010
Environment:
Last Closed: 2017-09-19 10:02:49 UTC
oVirt Team: Gluster
Embargoed:
rule-engine: ovirt-4.1?
sasundar: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 80914 0 master MERGED Trimed whitespaces in all the user provided text 2017-08-30 08:21:43 UTC
oVirt gerrit 80949 0 ovirt-4.1 MERGED Trimed whitespaces in all the user provided text 2017-08-30 12:05:50 UTC

Description SATHEESARAN 2017-08-21 10:45:13 UTC
Description
------------
The issue of **not** trimming whitespaces was already fixed for volume and brick properties with the bug 1455010. 

This bug is to request for the same fix on all the user input fields - hostnames, repository names ( comma separated ), package names ( comma separated ).

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHVH 4.1
cockpit-ovirt-dashboard-0.10.7-0.0.23

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. While specifying the volume name and brick's mount point, leave a space after  specifying the hostname ( or add a whitespace next to package name or repo-name )

Actual results:
---------------
The space is passed on the gdeploy config file.

Expected results:
-----------------
All the text that obtains the input from user should filter out the whitespaces

Comment 1 Red Hat Bugzilla Rules Engine 2017-08-21 10:45:19 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 SATHEESARAN 2017-08-21 10:50:05 UTC
Please make sure that all the user input fields in cockpit has the whitespaces removed.


Fields like repositories & package names can obtain the following values as input:

package1, package2 ----- should be corrected as ---> package1,package2
repo1, repo2       ----- should be corrected as ---> repo1,repo2

Also the leading spaces also should be trimmed

Comment 3 SATHEESARAN 2017-09-14 11:20:16 UTC
Tested with cockpit-ovirt-dashboard-0.10.8-2.0.ovirt41.el7ev.noarch

Trim spaces purposefully introduced with hostnames, brick names, and also with package names, repo names are filtered out.


Note You need to log in before you can comment on or make changes to this bug.